Offline files disabling itself

I have a couple of laptops running W7 on an SBS 2008 domain which have suddenly started disabling Offline Files (which is a pain because  i use Folder Redirection). If i enable offline  files i get  the message that it's not active yet and needs a restart but after the restart it has been disabled again. I have tried enforcing offline files through Group Policy (although no other computers have been affected)

Any suggestions?

Who is Participating?
chrisryan43Connect With a Mentor Author Commented:
Sorry i should have included that on my original post. When i am at the stage of having enabling offline files but being told i need to restart, the offline files service is set to Automatic but not yet running. When i start it manually the sync centre is happy that offline files is now fully enabled but i cant actually cache anything. When i restart the machine everything goes back to being disabled again
Emmanuel AdebayoGlobal Windows Infrastructure Engineer - ConsultantCommented:
Can you check to enusre that the REG_DWORD registry values is set to zero for:

HKLM\Software\Microsoft\Windows\ CurrentVersion\NetCache\Enabled
HKLM\Software\Policies\Microsoft\ Windows\NetCache\Enabled
Since you're using folder redirection, you might want to check the user's folder for a desktop.ini file and remove it to see if that helps.
Train for your Pen Testing Engineer Certification

Enroll today in this bundle of courses to gain experience in the logistics of pen testing, Linux fundamentals, vulnerability assessments, detecting live systems, and more! This series, valued at $3,000, is free for Premium members, Team Accounts, and Qualified Experts.

chrisryan43Author Commented:
The first key didnt exist so i have created it (i set it to zero but presumably zero disables offline files?) and


doesnt exist either
Nick RhodeIT DirectorCommented:
Can you check in group policy to see if its disabled?  Also before you setup folder redirection I would have edited the folder redirection policy and removed the exclusive rights option.
chrisryan43Author Commented:
It's not disabled in Group Policy (all the other machines arent disabling themselves so i dont think it's a group policy issue). I have removed desktop.ini but still no joy unfortunately

Any other ideas?
Nick RhodeIT DirectorCommented:
Can you open up the Services (services.msc) and check if the offline files service is disabled?
chrisryan43Author Commented:
I never did resolve it, i reformatted the machine so just closing the open question
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.