Certificate Error on localhost

Hi - I am trying to prevent "There is a problem with this website's security certificate." warnings when connecting to an internal wallboard system on the company server. The connection is https.
When I go to view certificate it is issued to 'localhost'. I can continue to install it and it tells me that "import was successful" but it makes no difference.

Any ideas?
LVL 1
paulmac110Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

XGISCommented:
Hello paulmac110;

you may try this _go to internet options and select the advanced tab and uncheck "warn about certificate address mismatch".

 You should avoid lowering your level of security if at all possible.  It is very important to only do one step at a time and undo it if it does not work.  Nothing worse than gaping holes that you cannot see or detect intrusions that may occur at any time

the not so recommended option...
check you internet options security tab.  select the "Trusted Sites" icon and set the Security level to "Medium Low".  Close all the Windows. Then open the browser.
this procedure has obvious implications for your machine security. Ensure that this approach is acceptable prior to implementation, based on internal security. etc
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
paulmac110Author Commented:
Tried the security settings "medium low" and even "low". Still getting certificate warnings.
0
Jerry MillerCommented:
If the URL is not localhost, I don't think that importing the certificate will matter. The warning is telling you the host names are different. You should reissue the certificate with the proper host name to correct the problem.
0
OriNetworksCommented:
You must import the certificate to all computers and devices that will be accessing that server. If you don't have access to all devices that will access it, you must get a certificate from a publicly trusted certificate authority, GoDaddy, Verisign, etc.

Or if it's only internal clients you can use OpenSSL to self-issue a certificate for the actual hostname being used.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.