• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 446
  • Last Modified:

vmware virtual machine corrupted when booting

I  have 3 virtual machines (win 2008) running on VMware server.
Last week the server crashed, and on the console window of one the virtual machines, I get a windows error 'bad or missing c:\windowssystems32 ..ntfs.sys is missing,  please insert ...' Result : all data for the 3 virtual machines was lost, and I had to rebuild the VMware and esx from scratch. Cab anybody explain me what could have caused the problem . I did not have a power failure
3 Solutions
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Were any snapshots attached?

what failed?

seems possible the VMDKs and/or datastore was affected.
Yes it seems you had a corruption on the vmdk files, would have been interesting if you tried to recover the Windows OS via the recovery console.

Also you can configure mini-dumps or full dumps if this has occurred before, should create a crash dump with the issue logged.
MolenBelgiumAuthor Commented:
I this a common problem, or rather exeptional
I'd say exceptional not had a ESX(i) host crash but once and that was due to an APD issue.
Does your host use local or remote storage? Did you run a diag on the server to check for hardware errors? Did you review your host logs?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now