Windows 8 pro - Remote Desktop will not /span multiple monitors

I have a windows 8 pro PC with dual monitors (one is a notebook).  When I run MSTSC with the /span option it will not display across both monitors.  When I use this same setup only on a Windows 7 PC it works fine.  I have also tried the /multimon and it does the same thing.

I have also modified settings in the .RDP file.
AndyZookAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Randy DownsOWNERCommented:
Maybe this will help

http://social.technet.microsoft.com/Forums/en-US/d6b80df7-6acb-4408-a3d4-251e5951bb86/multiple-monitor-support-with-remote-desktop-service-in-windows-8-pro

I have Windows 8 Pro and I can confirm that it supports discrete multiple monitor RDP session. I initiated the RDP session from my other Windows 7 PC by using the following command

mstsc /multimon

----------------

That is great but how about having 2 out of 3 monitors enabled for RDP.

Right now I must confirm that configuring multimon locally, or changing max monitors in group policys, or configuring RDP host server on client settings tab regarding max monitors does not work at all.

I see that this is a big issue for many who use 3 monitors. Whatever setting you change, you always will get just one monitor or all three. Clearly it does not work so please no advice how to change these settings.
0
AndyZookAuthor Commented:
Tried it.  No help.
0
Randy DownsOWNERCommented:
OK maybe this will work

http://social.technet.microsoft.com/Forums/windows/en-US/d6b80df7-6acb-4408-a3d4-251e5951bb86/multiple-monitor-support-with-remote-desktop-service-in-windows-8-pro?forum=w8itprogeneral

if you run (win+R) mstsc /?, it will show you /multimon.  If you run simply "mstsc" or click the "Remote Desktop Connection" icon, click the "Show Options" button, then go to the Display tab.  There is a check box that says "Use all of my monitors for the remote session".

I have tested both Win 8 Pro & Win 8 Ent with the /multimon and it checks that box, and opens RDP sessions across my three monitors.  Also manually checking that box works.
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

AndyZookAuthor Commented:
Ok.  I resolved the issue.  In Windows 8 (unlike Windows 7) for the /span option to work both monitors MUST have the same resolution.  Nice downgrade Microsoft!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Randy DownsOWNERCommented:
Glad you figured it out
0
AndyZookAuthor Commented:
It solved my problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 8

From novice to tech pro — start learning today.