USB Error Event ID 11

Lately, every time I plug a flash drive into any usb port on the computer (WIN764 Dell 980) I get Event ID 11 error with the following: "The driver detected a controller error on \Device\Harddisk7\DR12." Using different flash drives, the "DR" number changes, but the "Harddisk" reference is always 7. Tried three different flash drives and all produce Event 11 error messages.

 Here's the XML:
- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Disk" />
  <EventID Qualifiers="49156">11</EventID>
  <Level>2</Level>
  <Task>0</Task>
  <Keywords>0x80000000000000</Keywords>
  <TimeCreated SystemTime="2013-10-09T15:57:13.244080800Z" />
  <EventRecordID>412715</EventRecordID>
  <Channel>System</Channel>
  <Computer>MN-PC</Computer>
  <Security />
  </System>
- <EventData>
  <Data>\Device\Harddisk7\DR8</Data>
  <Binary>0E04800001000000000000000B0004C003010000000000000000000000082D0000000000000000003BBA050000000000FFFFFFFF060000005800000000000000FF0006120C000010000000003C0000000000000000000000C086950780FAFFFF0000000000000000603A9F0880FAFFFF0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000</Binary>
  </EventData>
  </Event>

And here's the friendly view of the same data:

+ System

  - Provider

   [ Name]  Disk
 
  - EventID 11

   [ Qualifiers]  49156
 
   Level 2
 
   Task 0
 
   Keywords 0x80000000000000
 
  - TimeCreated

   [ SystemTime]  2013-10-09T15:57:13.244080800Z
 
   EventRecordID 412715
 
   Channel System
 
   Computer MN-PC
 
   Security
 

- EventData

   \Device\Harddisk7\DR8
   0E04800001000000000000000B0004C003010000000000000000000000082D0000000000000000003BBA050000000000FFFFFFFF060000005800000000000000FF0006120C000010000000003C0000000000000000000000C086950780FAFFFF0000000000000000603A9F0880FAFFFF0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000


--------------------------------------------------------------------------------

Binary data:


In Words

0000: 0080040E 00000001 00000000 C004000B
0008: 00000103 00000000 00000000 002D0800
0010: 00000000 00000000 0005BA3B 00000000
0018: FFFFFFFF 00000006 00000058 00000000
0020: 120600FF 1000000C 00000000 0000003C
0028: 00000000 00000000 079586C0 FFFFFA80
0030: 00000000 00000000 089F3A60 FFFFFA80
0038: 00000000 00000000 00000000 00000000
0040: 00000000 00000000 00000000 00000000
0048: 00000000 00000000 00000000 00000000
0050: 00000000 00000000  


In Bytes

0000: 0E 04 80 00 01 00 00 00   ..¿.....
0008: 00 00 00 00 0B 00 04 C0   .......À
0010: 03 01 00 00 00 00 00 00   ........
0018: 00 00 00 00 00 08 2D 00   ......-.
0020: 00 00 00 00 00 00 00 00   ........
0028: 3B BA 05 00 00 00 00 00   ;º......
0030: FF FF FF FF 06 00 00 00   ÿÿÿÿ....
0038: 58 00 00 00 00 00 00 00   X.......
0040: FF 00 06 12 0C 00 00 10   ÿ.......
0048: 00 00 00 00 3C 00 00 00   ....<...
0050: 00 00 00 00 00 00 00 00   ........
0058: C0 86 95 07 80 FA FF FF   À¿¿.¿úÿÿ
0060: 00 00 00 00 00 00 00 00   ........
0068: 60 3A 9F 08 80 FA FF FF   `:¿.¿úÿÿ
0070: 00 00 00 00 00 00 00 00   ........
0078: 00 00 00 00 00 00 00 00   ........
0080: 00 00 00 00 00 00 00 00   ........
0088: 00 00 00 00 00 00 00 00   ........
0090: 00 00 00 00 00 00 00 00   ........
0098: 00 00 00 00 00 00 00 00   ........
00a0: 00 00 00 00 00 00 00 00   ........

Any help would be appreciated.
normanmlAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Nick RhodeIT DirectorCommented:
Try shutting the system down.  Physically disconnect the power and wait a few minutes.  Plug the power cable back in and power on the system.  Try it again
0
normanmlAuthor Commented:
Pulled the plug, waited a couple of minutes, replugged and powered on. Still getting Event ID 11 when I plug in any USB drive.
0
Nick RhodeIT DirectorCommented:
Did you try reinstalling the USB Controller drivers?

http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/event-id-11-logged-when-plugging-storage-device/a25c0957-4714-45de-8d7a-7a95bbca787f

Typically if this does not work you probably looking at some defective ports.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

normanmlAuthor Commented:
The instructions you referred me to say:  "2. In Device Manager, double click to expand "Universal Serial Bus controllers", right click on the "Host Controller", click "Uninstall" and click "OK".

As you can see in the embedded PNG file:

There is no "Host Controller." Also I assume you want me to uninstall the two Intel 5 drivers listed here as well? Finally, it occurred to me that uninstalling all this will disable the mouse, which I found listed in the power tab of the first generic USB Hub, so I'll uninstall that last.

I'm not sure about defective ports. I tested a corded mouse in all four ports on the front hub and the mouse worked. What's more, even though I'm getting Event ID 11 with every USB drive, the drives show up in WinExplorer. Anyway, if I'm correct about the above, I guess I should begin uninstalling from the bottom up, right?
Capture.PNG
0
nobusCommented:
i would start by testing this flash drive on another pc - it can simply be bad
0
Nick RhodeIT DirectorCommented:
Yes.  Also is this pc joined to the domain and storage devices are disabled and all that jazz via group policy?
0
normanmlAuthor Commented:
Also is this pc joined to the domain and storage devices are disabled and all that jazz via group policy?
I'm not sure what you mean. It's a WIN764Pro on a home LAN. No home group. I'm the only personality/administrator. I think you mean is this a workstation that an IT manager can control? No, it's just one of two home computers. Also the two flash drives in question work fine on an XP machine and leave no errors or warnings on the XP's Admin Events Viewer. And a further development: I've tested five USB drives on the front USB hub of four ports (mouse attached to one of the ports). Three of the USB drives now work fine -- two scandisks, one 4GB the other 16. Also and iECKO flash drive 4Gb works fine -- and by that I mean none of the above generate an Event 11. Two OTHER drives, however, two drives that are about two years and and reliable and not used very often (both SanDisks 4GBs) each leaving not one but two Event 11 warnings in the event viewer. I tested those two, again, on an XP machine and on a MacAir and both work fine. Again, no admin events are generated on the XP machine.

So where does this leave us. Still think I should uninstall all the USB hubs in device manager? I can't figure out why these two particular drives, which work fine elsewhere on many machines, don't like my Win764 and leave those warnings.
0
nobusCommented:
it looks like the usb portion of your PC is corrupt
do you get the notification sound when connecting?

you can always update your drivers for this PC -  start with chipset :
http://www.dell.com/support/drivers/us/en/19/Product/optiplex-980
0
normanmlAuthor Commented:
Yes, I get a notification sound whenever I connect a flash drive or device. I updated the chipset a few months back. How do I update the USB drivers? I have not yet uninstalled those USB hubs. What do you think?
0
normanmlAuthor Commented:
Okay, it came down to two particular flash drives that, though working just fine, kept throwing of Event 11 errors on a Win7 machine. First I tried the uninstall you suggested from here
http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/event-id-11-logged-when-plugging-storage-device/a25c0957-4714-45de-8d7a-7a95bbca787f
Problem is, once you uninstall the host controller, you use your mouse. I wonder if someone can tell me how to finish the uninstall of the hubs without a mouse. I had to pull the plug and reboot several times to get each of the seven hubs uninstalled. However, I still got the error 11. Then I tried http://www.techspot.com/community/topics/usb-drive-or-flash-problems-how-to-cleanup-and-remove-old-usb-storage-drivers.145884/ removing old storage drivers. Got rid of the garbage, but the errors remained. There must be something about those two, two-year-old flash drives that Win7 doesn't like. I've tested four other flash drives on the machine and none throw off the error. So I tossed the drives that were causing the error and we'll see what happens. Thanks for the help. PS: How do you uninstall USB hubs and still keep the mouse pointer so you can finish?
0
nobusCommented:
>>  How do I update the USB drivers?  <<  normally, they're part of the chipset driver

>>  how to finish the uninstall of the hubs without a mouse  <<  with the keyboard (PS/2) or by enabling the legacy keyb + mouse in the bios

test your drives with : http://www.softpedia.com/get/System/System-Miscellaneous/H2testw.shtml


not sure why you selected that answer??
if you want to re-assign points, you can ask a mod for help- use request attention
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
normanmlAuthor Commented:
Points were well earned. You helped me eliminate the possibilities. USB hubs work fine, old drivers for old devices cleaned out. Tested the flash drives with H2Test, which said they were fine. Still, those two particular drives still leave Event 11 notices. None of the other do. So there's something about them my machine doesn't like. I may try to reformat them on an XP machine. Anyway, data has been transferred to a CD so all's safe. Thanks again.
0
nobusCommented:
>>  Points were well earned.    << i did not get points
but i did suggest  H2Test, and how to install USB drivers
did you select a wrong answer maybe??
0
normanmlAuthor Commented:
Wrote to Admin here asking them to split points. I installed drive with a PS2 Keyboard. Took a while to figure out how to maneuver the page. Still can't figure out why the two drives in question will work on a MAC and XP machine and not on a WIN7 machine, or on this particular WIN machine while all the other USB storage devices and other devices work just fine on the machine.
0
nobusCommented:
if they don't work on a w7 system you can try to delete old installs from device manager ; select view show hidden devices
did you try different USB ports also?
0
normanmlAuthor Commented:
Went to device manager. No old installs or unused devices. Tried the two drives on every USB port on the machine. Same result. Looked in the registry and saw hundreds of entries for SanDisk drives, hundreds. If I guessed that there's something in the registry that is triggering that Event 11 for these two particular flash drives, would I be wrong. We seem to have eliminated everything else. Perhaps when I first used the drives, Win gave them a registry entry. Then I didn't use them for a while. In between were lots of Windows updates. I wonder....
0
normanmlAuthor Commented:
Thanks to both.
0
nobusCommented:
thanks all.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.