visual studio 2012 tests why do mine run after I rebuild my solution?

I have a vs 2012 solution that is using CUITe to automate website UI testing.  CUITe isn't really that important, but it is basically a wrapper for coded ui.

For some reason, my tests start to run after I rebuild.  This doesn't happen on a build or on anyone else's computer.  We are using TFS so I would think my settings should be the same as others.

How can I stop this and how can I see things that happen on a rebuild?
jackjohnson44Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bob LearnedCommented:
The only thing I can think of is this setting:

Run unit tests automatically with local builds
http://tfs.visualstudio.com/en-us/learn/run-a-unit-test-after-build-in-vs.aspx

Configure your solution to run unit tests each time you build locally.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jackjohnson44Author Commented:
Brilliant!!  That was such a pain to deal with.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.