WiFi Video Streaming in Classroom Environment

Is it reasonable to expect 19 devices to stream video simultaneously through one WAP?  I have SonicPoints in place at a school, which work great for standard html web traffic, but crater when a whole class runs YouTube.  

I understand that SonicPoints are lower grade, but will upgrading to a Cisco Aironet 2600 resolve this?  Thoughts?
LVL 1
Jordan SmithAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KimputerCommented:
Considering its 450 Mbps throughput, and assuming your devices run on the wifi-N hardware, plus one hd youtube stream is around 8-10 mbps, you could easily have 40 students. In this situation, it might be your broadband connection (or internal network, if it's limited to 100mbps) that might buckle under the stress (as I don't think there are special proxy or caching servers at your site). Each connection will download the stream seperately. Maybe it's wiser to download the videos yourself, and put the video files on a shared space (still, even this way, it's better to have 1gbps connection to the access point)
0
Jordan SmithAuthor Commented:
The WiFi is on a GB connection to the network. ISP is 20Mbps up and down.  I'm seeing the SonicPoints totally dropping all connections, not just slow.  

I guess my main concern is if I have the client drop $800.00 on a Cisco WAP, will it support the 19 connections at YouTube bit-rates?
0
KimputerCommented:
With the details you're providing, it's going to be a close call. And I don't mean the Cisco WAP, but your 20Mbps line. Are you telling me it's 20 MegaBYTE or 20 Megabit ? If it's 20MB (capital B, MegaBYTE), then you will have just enough bandwidth for all students grabbing the 720p stream (but what about the rest of the school?). If it's 20mb (mbit), you will have shortage.
0
Challenges in Government Cyber Security

Has cyber security been a challenge in your government organization? Are you looking to improve your government's network security? Learn more about how to improve your government organization's security by viewing our on-demand webinar!

Jordan SmithAuthor Commented:
YouTube should be streaming at .5 - 2Mb[its]ps  (360p - 720p respectively)  If everyone is streaming at 360p, then 20 downloads should only take 10Mbps.  Our ISP provides 20Mb[its]ps so we should be good there.

Any other comments on the sufficiency of the WAP hardware I'm proposing?
0
KimputerCommented:
Okay, you never corrected me when I was babbling along about the HD streams.
The Cisco is top end hardware,  you can't go wrong there.
But if you have a trusted supplier, I would suggest having a Netgear or D-link WAP on loan, and try that instead for a few days. That way the school might save hundreds of dollar and still get high quality products.
0
pgm554Commented:
Folks need to understand that the chances of getting 450 is slim to none.

It's theoretical!

WiFi works like this ,for every device attaching to an AP ,the bandwidth available halves.

Most cheap AP's are rated for 150 in the 2.4 band.

To get 450 you need the 5 and 2.4 bands and most of the time it's proprietary to the vendor.

Plus you need cards that will do 2.4 and 5,and lot's of wifi cards don't do both.

1 connection 150,2 connections 75,3 connections 25 and so on.
0
TMekeelCommented:
19 on one AP might be too many.
Have you tried decreasing the number of students connecting at once and see where it beings to fail?

Do wired clients on the network experience degradation on the WAN when the students are trying to watch YouTube?

It sounds like you need some sort of optimization appliance or traffic shaping, maybe a proxy or cache to do multicasting behind the firewall?  That way one connection grabs the video and multicasts it to the LAN?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sanjayrajtCommented:
Hi,

You can go with 600Mbps router whatever it is Cisco linksys or Netgear. Because as time of internet usage you can do better file transfer in LAN network gaming ext.But try to select dual band A/B/G/N and external antenna router it will give you better connectivity in long distance.
0
Craig BeckCommented:
40 clients on a 450Mbps AP might be good for standard web-browsing, but definitely not for streaming video.

Streaming video will kill a wireless connection.  I'd never ever expect more than a handful of clients to receive a useful service from a single AP at the same time when streaming video of any legible quality.

Upgrading to Cisco's 2600 series APs won't improve much here unless it's a high-density deployment using only the highest data-rates.  I'd suggest using the 3600 series APs with the 802.11ac module for this kind of requirement.
0
Jordan SmithAuthor Commented:
Craigbeck - Just to confirm, 40 connections was not part of the initial question, it was 19.

I am running a test in the classroom with the new Cisco WAP this afternoon.  I'll post back with results.

Thanks!
0
Craig BeckCommented:
Hi dbzmaxx - I know, I was referring to one of the other posts :-)

Even still, 19 clients trying to constantly stream video traffic will need some very fast data-rates.
0
Jordan SmithAuthor Commented:
Well, we got better performance using the Cisco 2600i, but still some pausing videos and some clients getting booted of the wireless signal for a little bit.  

I currently have the spectrum set to 20MHz, as other WAPs are near by and I'm trying to minimize interference.  I'm considering raising that to 40MHz, would that help the connection speeds?  Below is the config file, if anyone has any insight on it...

!
! Last configuration change at 21:25:37 UTC Tue Aug 13 2013
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname TIM-CLASS
!
!
logging rate-limit console 9
enable secret 5 $1$g5bO$TrH.dmbinM6ifZPREKqR//
!
no aaa new-model
no ip routing
no ip cef
!
!
!
!
dot11 syslog
dot11 vlan-name WiFiSSID35 vlan 35
dot11 vlan-name WiFiSSID30 vlan 30
dot11 vlan-name Native vlan 1
!
dot11 ssid WiFiSSID35
   vlan 35
   authentication open
   authentication key-management wpa version 1
   mbssid guest-mode
   wpa-psk ascii 7 <encryption>
!
dot11 ssid WiFiSSID25
   vlan 25
   authentication open
   authentication key-management wpa version 2
   mbssid guest-mode
   wpa-psk ascii 7 <encryption>
!
dot11 ssid WiFiSSID30
   vlan 30
   authentication open
   authentication key-management wpa version 2
   mbssid guest-mode
   wpa-psk ascii 7 <encryption>
!
!
dot11 guest
!
!
!
username Cisco privilege 15 secret 5 <encryption>
!
!
bridge irb
!
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption vlan 25 mode ciphers aes-ccm tkip
 !
 encryption vlan 30 mode ciphers aes-ccm tkip
 !
 encryption vlan 35 mode ciphers tkip
 !
 encryption vlan 1 mode ciphers aes-ccm tkip
 !
 ssid WiFiSSID25
 !
 ssid WiFiSSID30
 !
 ssid WiFiSSID35
 !
 antenna gain 0
 stbc
 mbssid
 speed  basic-1.0 basic-2.0 basic-5.5 basic-11.0 basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15. m16. m17. m18. m19. m20. m21. m22. m23.
 power local 19
 power client 10
 channel 2437
 station-role root
 no dot11 extension aironet
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.25
 encapsulation dot1Q 25
 no ip route-cache
 bridge-group 25
 bridge-group 25 subscriber-loop-control
 bridge-group 25 spanning-disabled
 bridge-group 25 block-unknown-source
 no bridge-group 25 source-learning
 no bridge-group 25 unicast-flooding
!
interface Dot11Radio0.30
 encapsulation dot1Q 30
 no ip route-cache
 bridge-group 30
 bridge-group 30 subscriber-loop-control
 bridge-group 30 spanning-disabled
 bridge-group 30 block-unknown-source
 no bridge-group 30 source-learning
 no bridge-group 30 unicast-flooding
!
interface Dot11Radio0.35
 encapsulation dot1Q 35
 no ip route-cache
 bridge-group 35
 bridge-group 35 subscriber-loop-control
 bridge-group 35 spanning-disabled
 bridge-group 35 block-unknown-source
 no bridge-group 35 source-learning
 no bridge-group 35 unicast-flooding
!
interface Dot11Radio1
 no ip address
 no ip route-cache
 !
 encryption vlan 25 mode ciphers aes-ccm tkip
 !
 encryption vlan 30 mode ciphers aes-ccm tkip
 !
 encryption vlan 35 mode ciphers aes-ccm tkip
 antenna gain 0
 peakdetect
 dfs band 3 block
 speed  basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15. m16. m17. m18. m19. m20. m21. m22. m23.
 channel 5240
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Dot11Radio1.25
 encapsulation dot1Q 25
 no ip route-cache
 bridge-group 25
 bridge-group 25 subscriber-loop-control
 bridge-group 25 spanning-disabled
 bridge-group 25 block-unknown-source
 no bridge-group 25 source-learning
 no bridge-group 25 unicast-flooding
!
interface Dot11Radio1.30
 encapsulation dot1Q 30
 no ip route-cache
 bridge-group 30
 bridge-group 30 subscriber-loop-control
 bridge-group 30 spanning-disabled
 bridge-group 30 block-unknown-source
 no bridge-group 30 source-learning
 no bridge-group 30 unicast-flooding
!
interface Dot11Radio1.35
 encapsulation dot1Q 35
 no ip route-cache
 bridge-group 35
 bridge-group 35 subscriber-loop-control
 bridge-group 35 spanning-disabled
 bridge-group 35 block-unknown-source
 no bridge-group 35 source-learning
 no bridge-group 35 unicast-flooding
!
interface GigabitEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
!
interface GigabitEthernet0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
 no bridge-group 1 source-learning
!
interface GigabitEthernet0.25
 encapsulation dot1Q 25
 no ip route-cache
 bridge-group 25
 bridge-group 25 spanning-disabled
 no bridge-group 25 source-learning
!
interface GigabitEthernet0.30
 encapsulation dot1Q 30
 no ip route-cache
 bridge-group 30
 bridge-group 30 spanning-disabled
 no bridge-group 30 source-learning
!
interface GigabitEthernet0.35
 encapsulation dot1Q 35
 no ip route-cache
 bridge-group 35
 bridge-group 35 spanning-disabled
 no bridge-group 35 source-learning
!
interface BVI1
 ip address 192.168.0.247 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.0.1
ip forward-protocol nd
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
 login local
 transport input all
!
end
0
pgm554Commented:
In order to get better throughput ,you must have a dual band WAP that does both 5 and 2.4.

It then will use both the 20 and 40 and give you better performance.

But as I said ,unless you have wireless cards that can do both 2.4 and 5 ,your throughput will still be 150 (theoretically) at best.
0
Jordan SmithAuthor Commented:
My ISP is only providing 20Mbps, so we'll never touch the entire 150 available.  My concern isn't throughput as much as the WAP supporting 19 concurrent connections all streaming .5-1Mbps, and not dropping the connections from overload.  Dropping the connection is the major indicator something is wrong, because even if the ISP bandwidth is maxed at 20Mbpx, the devices should still be connected to the WAP just fine which should be supporting up to 150Mbps.
0
Craig BeckCommented:
You can achieve 300Mbps using only 5GHz and 40MHz channel-widths.  You don't need dual-band for that.

Wifi is half-duplex so when a client is sending data the AP doesn't. This also means that only one client can transmit or receive at a time.  The more clients you add, the longer they have to wait to talk, so this gives the effect of less bandwidth.  To counteract this effect you need to reduce the amount of time a client needs to send data, and that is primarily achieved by using faster data-rates.

Try setting the SSID to use AES only on the radio interface to ensure you're using the 802.11n MCS data-rates for all clients.
0
Jordan SmithAuthor Commented:
We're still struggling with connections.  Will it be helpful to have 3 WAP's in one classroom?  Will the devices be able to intelligently select which WAP to connect to in this kind of density?  I am planning to set all WAP's on different channels, with the same SSID configuration and 1/8 power.  Thoughts?

Also, I am considering removing security on the SSID in question to eliminate WPA/WPA2 compatibility issues.  Would that have the expected effect on the system?
0
KimputerCommented:
I would suggest using three different ssid's, and you do the distribution yourself.  Play with the power settings, I'm afraid setting it lower could also impact the bandwidth. Removing security will free up more bandwidth, there's less overhead in the data. That is, if you're not afraid of outside snooping.
0
Jordan SmithAuthor Commented:
Adding additional WAPs has resolved the issue.  Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple Networking

From novice to tech pro — start learning today.