• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1440
  • Last Modified:

Mailbox move "Completed with Warning" Exchange 2010 SP3 RU1

Is this problem ever going to get fixed!! It takes so long to move a mailbox because I am getting these stupid "failed to cleanup source mailbox" warnings. I get the typical attempt 1/6 all the way to 6/6 in the log before it finally finishes. It adds at least 3 minutes to each move. Its a hack in Exchange that was supposed to get fixed many RU's ago and its still happening. Its documented in the RU1 update for SP3 and after applying this, I am still getting this warning? Does anyone know if there is a fix in the works or a work around for this. I need to move 3000 mailboxes and we are talking many hours of extra time because of this problem!!
Below is a section of the log. Mailboxes move fine, no errors on the move. It just takes so long. It doesn't happen with every mailbox. I would say at least 25% or so.

   at Microsoft.Exchange.MailboxReplicationService.CommonUtils.CatchKnownExceptions(GenericCallDelegate del, FailureDelegate failureDelegate)
10/9/2013 7:49:01 PM [EXSERVER1] Post-move cleanup failed. The operation will try again in 30 seconds (5/6).
10/9/2013 7:49:32 PM [EXSERVER1] Failed to clean up the source mailbox 'Primary (76fc3700-ec1b-4569-91b0-add520f1fea7)' after the move. Attempt 6/6.
  • 4
1 Solution
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
shadowtuckAuthor Commented:
No. Its a move from one DB to another in Exchange 2010 SP3 RU1. RU1 was supposed to fix this but it's still there.
Simon Butler (Sembee)ConsultantCommented:
No one knows what fixes are planned in future rollups, and those that do will be under an NDA. Rollup 2 for Exchange 2010 is available now.

Although I have moved 1000s of mailboxes between Exchange servers and it isn't a problem I have seen, so it must be something with your environment. Base don experience I would point the finger at AV or other plugins, particularly if they are from Symantec.

I have also seen similar issues with mailboxes with lots of junk rules, lots of delegates and things like that.

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

shadowtuckAuthor Commented:
Some of these are brand new mailboxes with only 1 message in them. The problem is documented in RU1 so it isn't my environment. Its a known issue and they said it would be fixed in RU1 and it is not. A simple Google search will show you its a common issue with a lot of frustration involved. The mailbox is none the worse after the move but it just takes longer because the final cleanup takes longer than it should. Read the release notes for RU1 in which the explain the problem. this is exactly what I am seeing.
shadowtuckAuthor Commented:
Well, RU4 has not addressed the issue either so I am giving up. Its never going to be fixed.
shadowtuckAuthor Commented:
No other responses. May escalate to MS product support.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now