Giving user permission to open another users mailbox

Exchange 2010 running on Win2008R2.

User needs to open another users folder.
I have given a user access to another mailbox by going to the mailbox proprieties and adding the user in the in the delivery options of the mailflow settings. But when the user tries to open the mailbox he gets an error saying he doesnt have rights.  When else do I need to add this user?
LVL 1
wannabecraigAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
There are two ways you could do it.  The user could grant access to specific folders via Outlook or to the whole mailbox with specific rights.  Or you could grant full admin via Exchange management.  For Outlook option, right click on desired folder, Properties, Permissions tab and set permissions accordingly.  For full access to the entire mailbox, follow instructions below:

In the console tree, navigate to Recipient Configuration > Mailbox.
In the result pane, select the mailbox for which you want to grant Full Access permission.
In the action pane, under the mailbox name, click Manage Full Access Permission. The Manage Full Access Permission wizard opens.
On the Manage Full Access Permission page, click Add.
In Select User or Group, select the user to which you want to grant Full Access permission, and then click OK.
Click Manage.
On the Completion page, the Summary states whether Full Access permission was successfully granted. The summary also displays the Shell command used to grant Full Access permission.
Click Finish.
0
wannabecraigAuthor Commented:
I don't want full permissions, I just want that user to be able to open the folder. Not delete, create new folder etc.  It's also not an actual user, it's just used as a mailbox for incoming mails, so cant grant access through outlook.
0
wshtyCommented:
why are you not able to grant access through outlook? you can just give yourself full permissions, then add the mailbox through outlook account settings to your existing profile and then set the permissions yourself. afterwards remove full permissions and mailbox from outlook.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

wannabecraigAuthor Commented:
Hi,

I'm not supposed to open the mailbox as it's a private one for job applications, so I dont want to open it of give myself permissions on it.
0
wshtyCommented:
hi,

then either you request a written permission saying that you are allowed to do it(i had the exact same problem as you and i solved it this way because it was way easier but it also depends on the company hierarchy etc..) or you try doing it with powershell (only possible with exchange-admin-rights of course)

i think the correct cmdlet is add-mailboxpermissions
with this you can also grant access to subfolders - but for me that was a pain in the ***...

try "get-help add-mailboxpermissions" on exchange shell for further instructions on how to use this cmdlet.

regards
0
Simon Butler (Sembee)ConsultantCommented:
Mail flow settings has nothing to do with accessing the content of the mailbox. You should remove the permission from there.
There is no read only permission at the mailbox level, only at the folder level. In order to open the mailbox in Outlook you will need to grant Folder Visible permission at the root, then Reviewer at the Inbox Level.

The command you need is add-mailboxfolderpermission:
http://technet.microsoft.com/en-us/library/ff522363(v=exchg.141).aspx

Set-MailboxFolderPermission -Identity user@example.com:\Inbox -User user2@example.com -AccessRights Reviewer

Simon.
0
wannabecraigAuthor Commented:
So if I use this shell command I dont need to add the users to the 'Full access permissions' role?  IS there a danger in adding them to the full access permissions if they need to send on behalf off too?
0
Simon Butler (Sembee)ConsultantCommented:
Full Mailbox and Send As/Send on Behalf of are two completely different permissions, unrelated to each other.

Therefore you can grant one and not the other (either way round).

What you don't want to do is set both Send As and Send on behalf of. One or the other.

If you set Full Mailbox, that trumps folder permissions.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.