Sharepoint 2010 - Outlook 2010 Contacts Sync Issue

All,

I have a customer with Office 365(outlook 2010) - he keeps his contacts in sync using the sharepoint website (more than 1000 contacts)

while this is actually not a real issue and everything is working fine, the customer complains about the following:

when he creates/changes a contact in outlook it is saved to sharepoint without problems - unless he changes or creates a contact and adds a website to the contact under website address.
if he fails to remind himself that he absolutely HAS to add "http://" to the beginning of the URL outlook will not sync this contact and will error out - all changes made to this contact are also not being synced.

my question: is there a way to circumvent this great "feature" of microsoft short of actually telling him that he must type "http://" before the url?

i have tried configuring the website field on sharepoint(no luck) and tried outlook forms(to add http automatically for every new contact) so far (and this could be something if there wasn't the issue of "oh what? you spent so much time on doing somthing like THIS?? I'm not paying for that" thing.

any other ideas?

otherwise i'll just write him an outlook reminder going off every 5 minutes to remind him of adding "http://" to contacts' websiteaddress.


thanks for your input

cheers
LVL 5
wshtyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rainer JeschorCommented:
Hi,
sorry but this issue / bug is something called "By design".

Hyperlink fields in SharePoint are validated before saving if they start with a valid protocol like http:// or https://.
Unfortunately there is no way to extend this check nor to deactivate this - especially not in SharePoint Online.

Therefore you are left with the following options:
- Do nothing on it
- Adjust the Outlook form to pre-check / pre-fill the field OR
- Make a copy of your list content to a non-synced list, clear all the list content, delete the field "Web page" in your SharePoint contact list, create a new field with the same name in SharePoint BUT set it to field type "Single line of text" and then copy all contacts from the backup to your synced list. Be aware that after deleting the column all content is lost.

HTH
Rainer
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wshtyAuthor Commented:
hi rainer,

thanks for your answer.
just to make myself clear in case i didn't at first:
i never said it was a bug - i know it is "by design" (well, whenever microsoft says something is by design it is just a paraphrase for "poorly coded and thought through"....) my customer is the one having a problem with it, not me - and in a way i can understand him:

you see, if you add contacts locally in outlook there is no problem with just typing "www." for example. so one would think that it does not matter how the url is actually typed in.
if this would be a good coded "by design", then microsoft would have added either a mandatory "http"/"https" also for local contacts, OR they would have implemented for the sharepoint url validation to automatically add http at the front if it does not exist.
(or they would have just left it out completely; this url validation functionality is somewhat ridiculous - why is there even any NEED to validate this?).

anyways - enough of my raging.. sorry for that. i just have to accept it.

i think you exhausted all possibilities here.
your third point is very intriguing - i will gladly try this (did you try that one yourself?)


since i don't see any other way of improving this i'll close my question and mark your post as answer.
thank you

regards
0
wshtyAuthor Commented:
addition: unfortunately your third option does not work.
in a test environment i can replace the website field with a "single line of text" but then the url i enter in outlook is not being recognized. looks like giving it the same name is not enough.
will have to revert to editing forms or sth like this.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.