C key on keyboard will not work via RDP

When connecting to the server via RDP the C key on the keyboard will not work. Doesn't matter where I am remoting from or what keyboard I use its the same problem. If I use a remote desktop sharing program (separate from RDP) the C key works fine. If I also console in via RDP the C key would work.

This is a physical server and the keyboard locally works just fine.
Who is Participating?
bmtservicedeskConnect With a Mentor Author Commented:
Issue has been resolved by changing the RDP settings for display to "High Color (15-bit)". Tested from multiple remote computers and it works successfully.

This was a MS Server 2003.
Jim P.Commented:
Are you reconnecting to a session that is already open, or to a new session?

Are you doing it via a VPN?  

I ran into a situation in the past where if I reconnected and the VPN was a "new" session it would turn on the <Ctrl>, <Alt>, or the <Windows> function key. It was irritating. The workaround was to hit the function keys in sequence and then try to type again.

The long term was log off the remote server gracefully, shut down the VPN and then restart the steps.
Have you tried replacing the keyboard?

Is this a wireless keyboard ?

If so could check batteries

For Me, I would just replace with another USB Keyboard and Test
regardless if it works locally
Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

Radhakrishnan RSenior Technical LeadCommented:

It could be due to the Keyboard language settings. Go to Control panel>>Region and Language>>Change keyboard and see the correct input language selected?

Why don't you start using On-Screen keyboad? start>>run>>osk.exe..it will bring the On-screen keyboard and you can type as you required (it's only my suggestion and it's up to you).

"Good Luck"
bmtservicedeskAuthor Commented:
jimpen - this is a terminal server and many people are on it and each of them have the same problem.

No VPN is being used just a normal RDP session using an external IP address.

The server has been fully shutdown and restarted and the problem is still present.

apache09 - I can try replacing the local key board but when I mstsc /console the c key works just fine. Since this is a terminal server not all users can console in.

radhakrishnan2007 - I checked this setting and it appears to be fine.

On board keyboard works and I can type the C however this is not a solution for my clients

Thank you all for the comments.
bmtservicedeskAuthor Commented:
bmtservicedeskAuthor Commented:
Fixed the problem by testing unrelated settings in RDP.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.