How to solve exchange2013 CU2 performance Counter updating Error 106

Dear All

After fresh installation of exchange2013 Cu2, it is noticed that periodically getting performance counter updating error. During the first installation, i thought the installation is not clean. I reinstall again the exchange2013 + windows2012, i got the same result.

After some research, it is noticed that many people are having the same issues.

What is the root cause?
How do i solve it ?

Experts, please help

Gordon TinIT ManagerAsked:
Who is Participating?
unknown_routineConnect With a Mentor Commented:
See here for the root cause:

To fix it Run copy the script on that page:

add-pssnapin Microsoft.Exchange.Management.PowerShell.Setup
$path = "C:\Program Files\Microsoft\Exchange Server\V15\Setup\Perf"
$items = Get-ChildItem -Recurse $path
$files = $items | ?{$_.extension -eq ".xml"} 
Write-Host "Registering all perfmon counters in $path"
$count = 0;
foreach ($i in $files)
   $f =  $, "\", $ -join ""
   Write-Host $count $f -BackgroundColor red
   New-PerfCounters -DefinitionFileName $f

Open in new window

to a text file and rename it as .

Note that this is a Power Shell script.

To run it . Goto Command line and type PowerShell
Then run the file and typeing its name:perfcounters.ps1
Seth SimmonsSr. Systems AdministratorCommented:
step 2 in the resolution states to run from exchange management shell, not regular powershell
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.