2008R2: Running rsop I get no result but error "invalid property"

Hi experts.

Unfortunately, I have no idea, when or how this started, because I haven't used rsop in a while: while this file server (2008 R2 SP1) is in excellent condition (event logs clean, no other problems), it is not able to display rsop data.
rsop.msc fails with the error message "invalid data", while gpresult /h %temp%\result.htm fails with "access denied" - please note that this command was launched from an elevated command prompt.

Note: the gpupdate is possible and succeeds.
Monitoring with procmon, I see no access denials at all, so I have no clue, what is going on.
Only tried sfc /scannow - no inconsistencies found.
Googled - found literally no one with this very problem.
Tried rsop from the server GPMC - same error.
Had a look at wmimgmt.msc ->properties - security - rsop and subfolders: all seems normal.

Any idea?
LVL 61
McKnifeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JaihuntCommented:
Check the below link it looks like the issue you are facing. It may help you.

http://www.windowstricks.in/2010/02/gpresult-failed-with-error-access.html
0
McKnifeAuthor Commented:
Hi.

That "trick" is not explained at all - I would not want to run commands that are not explained.
But anyway, already reregistering the userenv.dll fails: "module ...userenv.dll loaded, but Dll install procedure entrypoint  was not found - make sure it's a valid .dll".
0
McKnifeAuthor Commented:
Hi.

News: I converted that machine to a vm and unjoined it from the domain to do some tests and rsop+gpresult /h work again. Monday I'll join it again with a different name but same GPOs and see what's next.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

McKnifeAuthor Commented:
Well, what should I say... rejoined it, same OU... same security groups as the cloned server... works. Weird. Will try to unjoin/rejoin the original server soon.
Thoughts?
0
McKnifeAuthor Commented:
Finally had the time to do it. Disjoin/rejoin solved it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
McKnifeAuthor Commented:
Self-solved
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.