SBS 2003 Exchange dirty shutdown

Dirty shutdown due to power failure. Have attempted to repair message store using eseutil and isinteg. I have used the /P and /D switches. Because I didn't realize that both the edb and stm files would have temp copies the first defrag failed at 85% due to disk space. added switch to save temp files to alternate location and re-ran /D successfully. But as you can see isinteg fails. Public Folder store will mount, Mailbox Store won't. Event viewer application log has event ID 3005, 9175, 9518, and 9519 errors. files are not set to read only, Have tried http://support.microsoft.com/kb/896143 solution 3. Get this error when I try to mount  Mailbox Store http://support.microsoft.com/kb/289079 Temp files were saved in eseutil.exe /d /te:\Tempdfrg.edb /fe:\Tempdfrg.stm but were gone after defrag completed. I don't think I understand the instructions at this kb. Have also moved all files except edb and stm to temp folder but still couldn't run isinteg. have also restarted services as instructed in KB.


C:\Documents and Settings\Administrator>"c:\program files\exchsrvr\bin\eseutil.e
xe" /mh "e:\exchsrvr\mdbdata\priv1.edb"

Microsoft(R) Exchange Server Database Utilities
Version 6.5
Copyright (C) Microsoft Corporation. All Rights Reserved.

Initiating FILE DUMP mode...
         Database: e:\exchsrvr\mdbdata\priv1.edb

        File Type: Database
   Format ulMagic: 0x89abcdef
   Engine ulMagic: 0x89abcdef
 Format ulVersion: 0x620,11
 Engine ulVersion: 0x620,11
Created ulVersion: 0x620,11
     DB Signature: Create time:10/10/2013 21:37:30 Rand:33098039 Computer:
         cbDbPage: 4096
           dbtime: 14193790 (0xd8947e)
            State: Clean Shutdown
     Log Required: 0-0 (0x0-0x0)
   Streaming File: Yes
         Shadowed: Yes
       Last Objid: 5466
     Scrub Dbtime: 0 (0x0)
       Scrub Date: 00/00/1900 00:00:00
     Repair Count: 4
      Repair Date: 10/10/2013 14:03:35
 Old Repair Count: 4
  Last Consistent: (0x0,0,0)  10/11/2013 00:01:17
      Last Attach: (0x0,0,0)  10/10/2013 21:37:31
      Last Detach: (0x0,0,0)  10/11/2013 00:01:17
             Dbid: 2
    Log Signature: Create time:00/00/1900 00:00:00 Rand:0 Computer:
       OS Version: (5.2.3790 SP 2)

Previous Full Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Previous Incremental Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Current Full Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Current Shadow copy backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

     cpgUpgrade55Format: 0
    cpgUpgradeFreePages: 0
cpgUpgradeSpaceMapPages: 0

       ECC Fix Success Count: none
   Old ECC Fix Success Count: none
         ECC Fix Error Count: none
     Old ECC Fix Error Count: none
    Bad Checksum Error Count: none
Old bad Checksum Error Count: none

Operation completed successfully in 3.16 seconds.


C:\Documents and Settings\Administrator>"c:\program files\exchsrvr\bin\isinteg"
-s savent -fix -test alltests
Databases for server savent:
Only databases marked as Offline can be checked

Index  Status       Database-Name
Storage Group Name: First Storage Group
  1    Offline      Mailbox Store (SAVENT)
  2    Offline      Public Folder Store (SAVENT)
Enter a number to select a database or press Return to exit.
1
You have selected First Storage Group / Mailbox Store (SAVENT).
Continue?(Y/N)y
Isinteg cannot initiate verification process.
  Please review the log file for more information.

C:\Documents and Settings\Administrator>
LVL 7
rettif9DaleAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DhananjayTechnical ConsultantCommented:
Remove your old exchange transaction log file, which is store with your clean shutdown database then try to mount.

Make sure your database store location and exchange installation folder are excluded  in antivirus scan.

if still issue persists then.

Remove your exchange transaction log file then run the below command eseutil /p then eseutil /d then isinteg command. After complete try to mount the database.
0
Alan HardistyCo-OwnerCommented:
Are all your Exchange services running when you try to run isinteg?  They should be.

Alan
0
rettif9DaleAuthor Commented:
@ alanhardisty
yes all Exchange services are running except connector for POP3, exchange event, and site replicator serrvice.
@djsharma
The last time I tried to mount the mail folder I had already moved all files except the edb and stm files. After the mount failed new log files had been created.

Server has been running Symantec Endpoint Cloud for several months without issue.

When isinteg fails there is a message to review the log file but no hint of the name or location. Anyone happen to know?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Alan HardistyCo-OwnerCommented:
The error for isinteg suggests that the databases don't exist where exchange thinks they are, so please check the location via ESM and make sure they exist in that location and try isinteg again.

Alan
0
rettif9DaleAuthor Commented:
Log File Directory
C:\Program Files\Exchsrvr\SAVENT.log
Transaction Log location
C:\Program Files\Exchsrvr\mdbdata
System Path location
C:\Program Files\Exchsrvr\mdbdata

Maibox Store
Exchange Database
E:\ExchSrvr\mdbdata\priv1.edb
Exchange Streaming Database
C:\Program Files\Exchsrvr\mdbdata\priv1.stm

Public folder
Exchange Database
C:\Program Files\Exchsrvr\mdbdata\pub1.edb
Exchange Streaming Database
C:\Program Files\Exchsrvr\mdbdata\pub1.stm

Those seem to be correct but I may be missing something
0
Alan HardistyCo-OwnerCommented:
Why are the .edb and .stm files for the Mailbox Store in different folders?
0
rettif9DaleAuthor Commented:
C:\ is an 80 GB drive. I didn't do the original install.

Since the mailbox store is at E:\ExchSrvr\mdbdata\priv1.edb is there something that needs to be changed in the switches for isinteg?
0
Alan HardistyCo-OwnerCommented:
Is that where Exchange System Manager is configured to find the files (Properties of the Mailbox Store> Database tab)?
0
rettif9DaleAuthor Commented:
yes I cut/paste from that property sheet tab.
0
rettif9DaleAuthor Commented:
Alan I had remote assistance from a friend yesterday. He just told me that me copied the stm file to E:\exchsrvr\mdbdata so that eseutil would run. I was unaware of this, but the file is there. However the path hasn't been changed in Exch Mgr. debating what to do. This happened before I ran eseutil /P and /D so now I'm not sure which stm file was repaired. suggestions?
0
Alan HardistyCo-OwnerCommented:
Does the .STM exist in both locations?

If the file only exists in the same path as the .EDB, please update ESM and then run isinteg, or move the .STM back to the path in ESM and then isinteg should be happy.
0
rettif9DaleAuthor Commented:
E:\ has much more free space would rather change ESM.
0
rettif9DaleAuthor Commented:
ESM won't allow change. message box says "the specified destination file already exists"

So, I'm going to hide the priv1.stm in the C path in another folder, then copy the priv1.stm from the e:\ path to the c:\ path
0
Alan HardistyCo-OwnerCommented:
Move the .STM file out of the destination folder, then make the change in ESM and then overwrite the .STM file with the one that was repaired with eseutil, then try isinteg.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rettif9DaleAuthor Commented:
Alan,

I thought I might be able to do that but didn't want to try it till I had verification. I've already done what I described above. isinteg ran with 0 errors. both the message store and the public store are mounted. Just called the customer site. Users are getting mail. Thanks Alan
0
rettif9DaleAuthor Commented:
Thanks for quick responses.
0
Alan HardistyCo-OwnerCommented:
Excellent - glad it is all working again.

Alan
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.