• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 920
  • Last Modified:

Suse 11 SP3 Issues with Hyper-V 2012 (SLES)

We are having a problem where a Suse v11 SP3 guest on Hyper-V 2012 seems to be having intermittent connectivity issues.

Essentially we run a Suse VM which hosts our DataSync Product. Since Upgrading to SP3 and migrating from Vmware ESX to Hyper-V we have been having problems where occasionally network traffic to the VM is interupted every few hours for a few seconds. We aren't exactly sure how often but this is our best guess.

What is strange is that if we ping to or from the guest to or from outside the VM the issue doesn't seem to happen either at all or so infrequently as to cause no issues.

We aren't really sure how we can figure out what the issue is and fix it once and for all, we don't want to run a ping forever.
  • 3
1 Solution
Is auto-negotiate set anywhere in the networking path?  (Switches, virtual NIC on SLES, physical NIC on Hyper-V box).  Are there any settings that might "pause" the physical or virtual NIC inside the Hyper-V?

I've not had much time with Hyper-V, only various flavors of VMWare (ESX, ESXi, vSphere, VMWorkstation) so I am offering places I would check.

Is there a backup schedules to run? Anything else running regularly (inventory of vm etc)?
You could always run a perfmon on the HyperV host monitoring network i/o to see if there is an issue.
networknAuthor Commented:
No the problem happens all day every day. We tried the legacy adapter but it basically loses connectivity after a few packets.

Auto Negotiate is set everywhere.

I don't see any settings where the vm would be paused.
networknAuthor Commented:
Ok well there was a very strange problem that caused the issue. The sending server had a defunct network card that some of the traffic related to this product was going out on instead, even though it wasnt enabled. Once we removed the IP address from it, and deleted it from the system the issue was resolved. It wasn't an issue wit the Suse at all.
networknAuthor Commented:
It wasn't a SUSE issue after all.  We tracked down the issue after all.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now