Windows Server 2K8 DNS Server - A Record added to folder, not file

Whenever a site attempts to add a new A record for a particular domain they control (e.g. adding a server1 A record to the somedomain.com site for example to create server1.somedomain.com )  onto their Windows 2008 standard DNS server the record creates a separate folder first and then puts the A record file within that subfolder.  This A record was added before (without the additional folder) but then somebody on the site without knowledge of DNS tried to create other A records and messed things up.  One or more of those A records may have been variations or higher level domain names from the record (e.g. tried to add somesite.server1 ) so that now always creates a folder. We believe those bad A records have all been deleted.  But when we delete that folder and try to add that original A record name back in (e.g. server1)  it looks fine when the record is created but after rebooting it still for some reason creates a new folder to put it in.  Not sure if this is a registry issue or if it can be fixed in DNS, but we want to create the A record again (e.g. server1.somedomain.com ) and have the A record be at the root of the other records including A records for somedomain.com instead of creating a server1 folder and then putting the server1 A record within that folder. Sorry if the description of this problem was not too clear or a bit long, but any help on this would be appreciated...

TIA ...
LGroup1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Chris DentPowerShell DeveloperCommented:
It'll almost certainly be the tombstoned entries for the records you've deleted. You can't see them, but they exist and probably cause a folder to be spawned for it.

If you're to wait for the tombstone records to go you'll need 14 days (by default). At that point they either become normal deleted objects (and are AD tombstoned as opposed to just DNS tombstoned) or are simply removed entirely.

It is possible to hack around it, but there's no chance that such a thing would be supported, so if something breaks you'd be in a not-very-fun place.

Chris
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
arnoldCommented:
Is the reference
Somedomain.com
Server1
    IN A 10.x.x.x
Server2
      IN a 10.x.x.y

Or
Somedomain.com
Server1
Server1 IN a 10.x.x.x
Server2 IN a 10.x.x.y

Check the view settings.

Were there any changes made to DHCP scope options? Or GPOs?
0
LGroup1Author Commented:
No changes to DHCP scope or GPOs - and the first reference seems to apply.   I think that it may be the tombstoned records as mentioned above.  Thanks all !
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.