SCO Unix Printer only works for root

Recently had to setup a new SCO Unix System 5 computer and we installed a network printer.

It prints perfectly if I am logged in as root, but any other user is unable to print.  I hunted all over for some kind of access file or permissions that would block other users but I can find none.  Can someone point me to a place to check?  

From a command prompt, I type a simple lp command, it looks like it worked but nothing prints.  Same exact file and command logged in as root and it works just fine.

$ l f1011*
-rw-r--r--   1 filepro  group      11811 Oct 11 17:10 f1011.txt
$ lp f1011.txt
request id is T634-100 (1 file)

Printer stats look like this:

scheduler is running
system default destination: T634
device for T634: /dev/null
T634 accepting requests since Fri Jul 19 14:37:05 2013
printer T634 is idle. enabled since Fri Jul 19 14:37:05 2013. available.

I checked /dev/null and I am sure anyone would be able to access that.  Since this is a network printer, I am not sure where it actually goes to get to the printer.  Obviously an IP Address, but I don't know where to check for that device.

Be glad to add any information necessary that I have overlooked.  The printer has all users listed on the Allowed side in scoadmin.  

Any help would be appreciated.  The tech that setup my system, seems unable to resolve this issue.  You pay someone that should know this stuff and it turns out they leave you hanging.
nlpalmquistAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mikelfritzCommented:
Check the permissions of /etc/hosts  - should be 0644
0
mikelfritzCommented:
you could look at the output of

ls -al /etc/hosts

Should be lrw-r--r-- for permissions.  If it's not the you can issue

chmod 0644 /etc/hosts

You may also want to look at the actual hosts file for permissions - that is  /var/opt/K/SCO/tcp/2.1.1Ga/etc/hosts

The /etc/hosts file is usually a link to that location.
0
nlpalmquistAuthor Commented:
/etc/hosts permissions : lrwxrwxrwx
/var/opt/K/SCO/tcp/2.1.1Hw/etc/hosts:   -rw-r--r--    as suggested.

That is not it.
0
Become a CompTIA Certified Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

mikelfritzCommented:
Try:
scoadmin -> software manager -> software menu -> verify system -> normal system state

This will list problems it finds, you should be able to look through the list and see if any permissions are amiss.

Also look at the permissions of the interface script for the printer in:

/var/spool/lp/admins/lp/interfaces
0
mikelfritzCommented:
also,  is the user getting any mail from the lp subsystem with complaints?
0
nlpalmquistAuthor Commented:
Sorry it took me a few days to get back to this.

I can see that the user did get a report in mail that reads:

Reason for failure:

/usr/spool/lp/admins/lp/interfaces/T634[36]: /usr/spool/lp/model/HPLaserJet: can
not execute

I also checked the integrity following the earlier post instructions since that seemed related.  Only 3 fixes and they did not affect the issue at hand.  This is a brand new install so there has not been time to mess it up too much.  Only changes to OS has been in trying to get the printer issue resolved.

The permissions on the file it can not execute would be:

drwxr-xr-x  57 root     bin         2048 Oct 18 15:26 /
drwxrwxr-x  29 root     auth         512 Jul 31 15:36 /usr
drwxrwxr-x  10 root     bin          512 May 20 14:52 /usr/spool@
drwxrwxr-x  10 bin      lp           512 Aug 12 09:45 /usr/spool/lp
drwxrwxr-x   2 bin      lp          1024 Jul  8 16:03 /usr/spool/lp/model
-r-xr-x---   1 bin      lp         19298 May 15 17:44 /usr/spool/lp/model/HPLaserJet

They look right to me. I know it works for root so the files certainly work.  All the users belong to "group", if that helps.

Thank you so much.  This is closer than I have gotten before.  I am resisting the urge to make all the files 0777, which I expect will fix the issue but would be a bad solution if I want to protect security.
0
mikelfritzCommented:
What are the permissions on /usr/spool/lp/admins/lp/interfaces/T634


You could try changing the permissions on HPLaserJet to 0555 to allow other to read and execute as a test.
0
mikelfritzCommented:
Also post listing of /usr/bin/ files lp lpstat and cancel, and /var/opt/K/SCO/Unix/5.0.6Ga/usr/bin/ files lp lpstat and cancel

I see a fix but I htink it's meant for older SCO 4.2 systems  Found here:

http://aplawrence.com/Unixart/netprint.html


cd /usr/bin
chmod 6711 lp lpstat cancel
chown root lp lpstat cancel
chgrp daemon lp lpstat cancel

Of course on your system the files really exist in /var/opt/K/SCO/Unix/5.0.6Ga/usr/bin/
0
nlpalmquistAuthor Commented:
I think you found my problem.  When I looked at the links for lp lpstat and cancel, they link to

-rwxr-xr-x   1 root     lp          1008 May 15 22:06 cancel -> /opt/K/SCO/cups/
1.1.23Ba/usr/bin/lp
-rwxr-xr-x   1 root     lp          1008 May 15 22:06 lp -> /opt/K/SCO/cups/1.1.
23Ba/usr/bin/lp
-rwxr-xr-x   1 root     lp          1008 May 15 22:06 lpstat -> /opt/K/SCO/cups/
1.1.23Ba/usr/bin/lp

I know I requested they setup the Unix box with cups, because that is what I had used on my previous box.  It worked great.  This techie was not comfortable with cups and setup with netcat when the initial installation was being tested.

I think it is the root of my problem.  I need to undo the netcat stuff and finish the installation with cups.

Could you provide any info on doing that?  It does look like cups is installed or I would not have the folders above.

Thanks so much
0
mikelfritzCommented:
Lets see if you are using cups first.
What print system does it show in  /etc/default/lpd

One thing that needs to be done with CUPS is to run mkdev rlp BEFORE cups gets installed.  running after breaks things.

http://wdb1.sco.com/kb/showta?taid=125723

Basically - uninstall CUPS, run mkdev rlp, install CUPS.  

I have not run CUPS on any SCO boxes I support (I'm down to less than a handful now).  I'll do my best to help here.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nlpalmquistAuthor Commented:
I am sure the issue is a mix of CUPS and NETCAT installs.  Since my lp commands all link to CUPS folders and the setup was trying to do netcat.  I am totally out of my element on how to uninstall or install and setup from scratch.  That is why I paid the tech to do it.  

I appreciate your help and you did get me moving in the correct direction to continue to get this issue resolved.  I just do not have the time to devote to trying to learn how to configure this right now.  

So I am closing this issue at this point.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.