how to change or set the default timedout sessions time

Hi All,

Please help me to change the default timeout settings in RHEL 5.5 and RHEL 6.2.

means when remote server doesnt respond it timed out after 5 minute - also when i open a new remote/puuty session it takes 1 minute to timedout .

Please help me how to change or set these limits as per our app need.
apunkabollywoodAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

slubekCommented:
In PuTTY: Options>Connections set "Sending null packets to keep session active" value and check the "Enable TCP keepalives (SO_KEEPALIVE option)" check box.
These options can be named different in different PuTTY versions.
0
apunkabollywoodAuthor Commented:
Thanks for ur info Slubek - But are you sure that this kind of settings need to be change only from putty side - there is no option  in OS?
0
apunkabollywoodAuthor Commented:
Actually i am talking about users login in OS who needs to be logged in even without any activity for some scripts / applications like oracle and apache
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

slubekCommented:
1. You can be logged-in without connection with screen command.
2. If your server closes connections that are idle for too long, set ClientAliveInterval option for example, to 60 seconds in your /etc/sshd_config.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
apunkabollywoodAuthor Commented:
But both are used for SSH sessions - okay problem is also comming when i am trying to telnet a DB or application server which are down. on both RHEL 5.5 and RHEL 6.2 there is diffrence in timeout time .

let say on rhel 5.5 it take 1 minute for timeout and on rhel 6.2 it takes 5 minutes - this behavior creating issue for app clusters. can we fix this or can we change it as per our need?
0
apunkabollywoodAuthor Commented:
sorry for delay but thanks it works
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux OS Dev

From novice to tech pro — start learning today.