New Windows 8 Laptop won't stay connected to wireless router

Have a new HP Pavilion laptop running Windows 8 that doesn't want to stay connected to the wireless router.  It connects and stays connected to 2 other wireless routers I tried.  

Windows will say it connects then it will say it has, "limited connection."  Doing and IPCONFIG shows no default gateway.  If you run the troubleshooter it says the issue is with the router.  However, no other devices have problems connecting to the router.  

I've installed and uninstalled the wireless adapter on the laptop.  Deleted the configuration for the wireless network and manually readded it and it still will either join for a few seconds then disconnect or simply say, "can't connect to this network."

Ideas?
CraigSNYCAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CraigSNYCAuthor Commented:
When I check the status of the wireless adapter it says, "Attempting to authenticate."

I checked the router and it's assigned an IP address to the laptop.  However, the laptop never "registers" it or the default gateway.
0
CraigSNYCAuthor Commented:
Also -- Under "Details" of connection, on WiFi Status the IP address of the gateway is shown as is the laptop's assigned IP.  However, it never appears when you do a, IPCONFIG in a command prompt window.
0
David Johnson, CD, MVPOwnerCommented:
The router isn't sending the DHCP information or for some other reason the dhcp information isn't handshaking.

have you tried setting up a static ip address, network settings /adapter/ipv4 properties?  A scan for malware using malware bytes is always a good idea
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

JohnBusiness Consultant (Owner)Commented:
Go to Device Manager (System Properties) and select the Wireless NIC. Right Click and select the Power Management tab. Uncheck (deselect) the setting to "Turn this device off".

Then go to Power Management (Control Panel) and select Advanced Properties. Expand the Wireless settings and set both AC and Battery to Maximum Performance.

Make sure these settings have held, and then restart your laptop and test.

I did the above on my Windows 8 laptop (and Windows 7 and Vista before that) and my wireless stays on all the time.

You might also see if there is an update to your wireless NIC. If there is and if you update it, check the above two settings again.

.... Thinkpads_User
0
CraigSNYCAuthor Commented:
@thinkpad: I tried your suggestions and they didn't work.  Right after boot the system made a connection then went to, "limited."  

I'm going to look for another driver for the adapter.

@ve3ofa: the system is new, out of the box, so i'm going to assume there are no viruses.  i'd prefer the system be able to grab a new IP address from the router, but I may try the static route and see what happens.
0
JohnBusiness Consultant (Owner)Commented:
I never had to use a static IP on my Windows 8 laptop (or any before that), so you should be able to get DHCP from your router.  Try the new driver.

If the system is new (and Windows 8), are you using the sidebar (from Metro) to connect wireless?

Also, does your router (older maybe) support the new card of your Windows 8 machine?  I have seen that before.

... Thinkpads_User
0
JohnBusiness Consultant (Owner)Commented:
Try a "divide and conquer" approach.

1. Try a different laptop on this network. Result?

2. Try the new laptop in a different network. Result?

... Thinkpads_User
0
CraigSNYCAuthor Commented:
@think:

1. there are 8 other devices on this network.  this is the only windows 8 system.
2. took the laptop to my office yesterday when it wouldn't stay connected at the client's.  once i did all the microsoft updates the connection was fine.  i brought the system in this morning and it worked fine for about 30 minutes.

i just downloaded an older driver from hp, for the adapter.  it's a ralink 3290, by the way.  it worked for about 2 minutes and lost "internet connection."  

could there be something up with the router?
0
CraigSNYCAuthor Commented:
sorry, just saw your other answer:  the router is pretty new.  the client just had it installed about 3 months ago.  it's a motorola  sbg6580.
0
JohnBusiness Consultant (Owner)Commented:
once I did all the Microsoft updates the connection was fine.  ..... could there be something up with the router?

Yes, it could be the router is not compatible. I do not like to condemn a new router, but wireless is as much an art as a science.

Is the card in the HP Laptop replaceable?  Consider trying a new and different brand of wireless. Does HP support Intel Wireless? My Intel wireless NIC's (2 laptops) have worked everywhere.

... Thinkpads_User
0
CraigSNYCAuthor Commented:
@think: i don't know if the wireless adapter is replaceable.  i'll check hp's website.

stay tuned.
0
McKnifeCommented:
Hi.

I had this problem once, maybe the same solution applies for you.
Problem was that the Wireless NIC did not "like" the router to be configured to use both WPA and WPA2. After changing to WPA2 only, the connection problems went away for good.
Note that this was only one computer, while all the others connected without problems in the wpa/wpa2 mixed mode.

If that does not help, try to use no wireless encryption for a test.
0
AkinsdNetwork AdministratorCommented:
Reset the network interface on your computer
Also, disable ipv6 in the Wifi NIC properties

To reset, launch command prompt as administrator

netsh interface ip reset
netsh winsock reset


Reboot
0
ded9Commented:
Try connecting the router in safe mode with networking.

If able to connect then problem might be caused by some program running at startup. Do clean boot to find the faulty app.

http://support.microsoft.com/kb/929135/en-us

Safe mode with networking

http://windows.microsoft.com/en-us/windows-8/windows-startup-settings-including-safe-mode
0
nobusCommented:
>>  It connects and stays connected to 2 other wireless routers I tried.  <<  this points to a router problem
i suppose you tried a poweroff/on cycle? or reset it to factory settings?  if not, try that first

it can be the router is just bad - test it with other systems
0
David Johnson, CD, MVPOwnerCommented:
If things work fine everywhere else but with this one router then I'd suspect the router more than the new computer.

Also assuming that if you use the wired connection it works just fine. A router power/cycle or reset hasn't helped at all?  You're set for WPA2-Personal and you've confirmed that the password is correct?
0
pgm554Commented:
Who is the ISP?
Did they sell the modem to the customer?
Could be a firmware bug on the modem,but the DOCSIS spec does not allow the end user to upgrade manually,only the vendor.
I would call them and have them log in to check for issues.
0
CraigSNYCAuthor Commented:
UPDATE:

I called HP.  No great surprise, they were no help.  "We'll call you back in 2 hours, after we do some research"  In the meantime I logged onto the router and decided, for some unknown reason, to turn off 802.11n mode from "auto" to "off."  ...and it works!  

Can someone explain this to me?  

Thanks for all the great input!!
0
AkinsdNetwork AdministratorCommented:
0
nobusCommented:
see my post above
0
JohnBusiness Consultant (Owner)Commented:
The auto setting affects G, N and Combination mode.

So it was the router (at least the router setup) all this time.

... Thinkpads_User
0
CraigSNYCAuthor Commented:
YET ANOTHER UPDATE:

HP called last night and I informed them what fixed the problem but I view it as a temporary workaround.  After some prodding on my part they agreed to get me an updated driver that should make the adapter work in 802.11n mode.  

@think:  I think I'd say the issue is really the wireless adapter's inability to handle 802.11n communications.  Would you agree?  

@Akinsad: thanks for the info!!! I'll check it out.  

I won't close the question until I'm done with HP and their driver update.
0
JohnBusiness Consultant (Owner)Commented:
I think I'd say the issue is really the wireless adapter's inability to handle 802.11n

It could be either, but you need the new driver to test. It is one of the two, which is more or less where we started from.

I have a ThinkPad X230 where wireless was working all along. A recent driver caused issues with the router (because our iPhones also dropped). Ultimately a very new Intel (not Lenovo) wireless driver cured the problem.

... Thinkpads_User
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CraigSNYCAuthor Commented:
@Think: thanks!  

A point of clarification:  most devices on this network use 802.11g, so it's a mixed network.  Am I correct in saying that because it's mixed you really don't benefit that much by having 802.11n devices because the 802.11g devices slow down the entire network?  So, ultimately, it's not that big of an issue?
0
pgm554Commented:
If the n is using the 40 mhz 5ghz spectrum ,that not entirely true as the G band is primarily 2.4 ghz.
0
JohnBusiness Consultant (Owner)Commented:
@CraigSNYC - Thanks, and I was happy to help.

.... Thinkpads_User
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 8

From novice to tech pro — start learning today.