• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1496
  • Last Modified:

Partition changed from ExFat to Ms-Dos

10.8 MacBookPro
I partitioned the SSD to three partitions, main (OS), MacE (ExFat) and MacD (ExFat).
All seemed to be fine. Then after a few days the MacE disappeared and when I checked under Disk Utility it was simply unmountable, disk repair failed, same for verification. I simply did a reformat because I had the data on external storage. Now the same issue happened to the MacD after a few days. The only data on it were the .vdi files (virtual disk) of VirtualBox. I did resize the .vdi, but it worked after that and there were no issue. This happens when I restart my Mac as I noticed.
I need my .vdi and it would save me time to remount it again. Plus I should know really why this happens, I have just migrated from Windows to face this shock. Listing disks under Terminal shows the MacD but with no name!
In the Disk Ut. it shows as disk0s5 and greyed.

diskutil list
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *751.3 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            177.0 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
   4:       Microsoft Basic Data MacE                    382.1 GB   disk0s4
   5:       Microsoft Basic Data                         191.3 GB   disk0s5 ---<this is the partition, no   name>

Errors when Repair/Verify:
Verify and Repair volume “disk0s5”
Checking file system** /dev/disk0s5
Invalid sector size: 0
Volume repair complete.Updating boot support partitions for the volume as required.Error: Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files.
Verifying volume “disk0s5”
Checking file system** /dev/disk0s5
Invalid sector size: 0
Error: This disk needs to be repaired. Click Repair Disk.
  • 2
1 Solution
TheSilverBulletAuthor Commented:
I fixed the problem:
this link says it all

The bottom line is that the ExFat on Mac seems to be fragile as reported by many people. So, you have to use
sudo fsck_exfat -d DISKNAMEHERE
Then it renders repairable on the disk utility.
TheSilverBulletAuthor Commented:
no fb
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now