• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1275
  • Last Modified:

Amazon EC2 Windows 2008...FTP access from outside not working

hi  guys

i have a windows 2008 R2 server in the Amazon EC2 cloud. I have set up FTP, with basic authentication to an FTP folder. This folder is shared and permissions for specific users are given to access it. Locally when I try, I am able to logon just fine.

I've gone into the security groups on the EC2 instance and permitted ports 21 and 22 from any source (i.e.

I am using Filezilla to connect to this. Whatever I do, it says 'Connection timed out, could not connect to the server'. I've even added the key pair in Filezilla.

My question is, what username/password should I be using to connect? I'm using the user I created on my windows server along with the password. I'm confused? Any help would be great

1 Solution
Emmanuel AdebayoGlobal Windows Infrastructure Engineer - ConsultantCommented:

You are correct with what you are doing. You might need to speak to Amazon ec2 tech guy. I have had this issue before and there was a configuration issue with Amazon ec2 that was solved by the support guy.

Port 22 is for SFTP and IIS doesn't do that.

Port 21 is the FTP control channel but FTP also needs a data channel.  This will be a port above 1024 that is negotiated during the FTP session.  If you are connecting with an FTP client like FileZilla that supports passive mode data channels then you can configure the FTP server software to use a specific range of ports for passive data channels.  This range will need to be open on the firewall for inbound connections.  

If you need to support older FTP clients like that ftp.exe command line client that comes with DOS then you'll potentially need to make outbound connections on any port over 1024 specified by the client.
Setup the windows server firewall... It always blocks everything on new EC2 Windows servers
YashyAuthor Commented:
I didn't get a chance today guys. I'll look again tomorrow and update.

p.s - I did enable FTP service and the host process for windows.

Think AlexPace's method I'll need to try tomorrow and see.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now