asa hair pinning

Experts,

allow me to give you a scenario and you let me know what my options are or if it is even possible.

This is in regards to my simple home network which has an ASA 5505 connected to DSL.

I have 1 public IP from the ISP 50.50.50.50. I have a security camera on my internal network 192.168.0.10/24 listening on port tcp 9000. I have port forwarding setup so that i can access my camera from outside.  Everything works fine in this manner. Example, the software to access my camera from outside is pointed at 50.50.50.50:9000.
The problem is when I am inside the network, i have to manually repoint the IP to 192.168.0.10:9000.  Would someone offer me a suggestion on how I could access 50.50.50.50:9000 from inside the network so that I dont have to keep flipping my ips?  This is ASA 8.4 code. would appreciate a sample syntax as well.
trojan81Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TimotiStDatacenter TechnicianCommented:
The ASA does support hairpin NAT, but it's usually a pain to set it up. Still better than with IOS routers.
Can you post your NAT-related config?

Tamas
0
Henk van AchterbergSr. Technical ConsultantCommented:
object service TCP-9000
 service tcp destination eq 9000

nat (inside,inside) source static any interface destination static 50.50.50.50 192.168.0.10 service TCP-9000 TCP-9000 unidirectional no-proxy-arp

here ya go. The source is changed to the interface IP of the ASA, this way the return traffic also goes via the ASA.

The downside is that in the logs you do not see the IP. To overcome that you can NAT to a POOL the same size as your LAN and then you will see the 1-to-1 NAT IP.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
trojan81Author Commented:
wow that worked beautifully! thanks henkva!
I don't have the option for "no-proxy-arp" at the end, but doesn't appear I need it.
0
Henk van AchterbergSr. Technical ConsultantCommented:
The no proxy arp is from the 9.0 software i think. You should consider upgrading ;-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.