Slow Browse Folders on network share

Have an issue with a network share (sbs 2011)
When saving a file to the share, either as smb path or mapped drive, the explorer box takes 2-3 minutes to show the contents of the folder.
It happens to any computer on the network, any subnet (3 locations) any os.
Also it doesnt matter if it is Notepad, word, excel it does this.
There are 63 sub Folders.
It happens with Either Save, Save as, or Open.

I have also found the issue occurs on the server that holds the share.
The drive that holds the share will show all folders at the ROOT of the drive, but open any of them up and you get the 2-3 min wait. So im thinking the drive is at fault, it however passes a chkdsk with no errors.

The kicker is, if you change the file type from .txt or .xls etc to ALL files (*.*) before selecting the share, it instantly shows the entire content of the drives. It only misbehaves when you have the specific extension selected.

This one has me stumped, any help is appreciated.
managedsolAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sumit GuptaSystem and Virtualization EngineerCommented:
Microsoft Office File Validation may be causing the problem.  that will give you the relevant solutions.
Also try:

Go to Excel
File
Excel Options
Trust center
Trust Center Settings
Trusted Documents..
TICK should be on, => Allow Documents on Network to be trusted.

Also try with/without anti-virus disabled - if AV affects speed then make sure that the AV is configured NOT to check network drives.
I recently fixed a similar problem for a client by cleaning all "offline folder" references in the registry - changed "\\<server>\users\<username>"
to "\\server[1]>"\redirectedfolders\<username>"

At last try:

Disable TCP/IP NetBIOS Helper Service and i hope it will be fine after this.
0
managedsolAuthor Commented:
Found the cause, it was a HTML shortcut in one of the folders on the drive.
Right clicking it took a few minutes to get a menu to appear, and deleting the file resolved the issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
managedsolAuthor Commented:
Resolved issue by myself
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.