Citrix Receiver 4.0.1/Win 8 issue

When I have a windows 8 computer outside of my private network I will get the error message below:

"Unable to launch your application. Contact your help desk with the following information:
Cannot connect to the citrix xenapp server. There is no citrix XenApp server configured on the specified address"

If I am on my internal network I do not get an error and apps launch as expected.

When I have a windows 7 computer I don't have any errors in either situation and apps launch as expected.

The version of windows 8 I am testing this on is not the ARM/RT version. The citrix receiver version I have is 14.0.1.4. I am running xenapp 6.5 with webinterface 5.4 and storefront 2.0. All server 2008 R2.
Attached is a print screen of the error message.

Same version of receiver on both win 7 and 8. I also tried a legacy version of receiver 3.4 on the win8 system and had the same result. .
The receiver is configured the same on both systems going to the same WI.
The external access solution is CSG and I also built a second system with just storefront2.0 right now.

Can anyone offer any suggestions as to how this can be resolved?
kwoznica732Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kwoznica732Author Commented:
Just an update. I also seem to have the issue on windows 7 going through the WI but not the receiver. I just did another test to make sure.
kwoznica732Author Commented:
I discovered that the issue was in specifying the access methods in the Secure Access Settings of the Web interface management console. I had a rule for the LAN in which the servers were sitting in and once I removed that rule this issue went away.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.