Access 2010 Visual Basic Method Errors with Windows 8 tablet

Hi experts:

I am have a new Tablet with Windows 8 installed and Office 2010, including Access 2010. The front end application that I have on the tablet is the same front end app that is on all the other machines currently in the office and it has been working since it was created 6 months ago. The other machines are either Windows XP Pro or Windows 7 pro (everyone has same version of office 2010).

We have a form that keeps failing with the error message that

Microsoft Visual Basic

Run-time error '-2147417848 (80010108):
Method 'RowSource' of object '_ListBox' failed

I have been trying to solve, and decided first I would compile and when I do I get this error (on the line for strPartNum = Me.Pt_IDN):

Compile Error:

Method or data member not found

So - I am starting to think something is wrong with the references. The MDB was created in Access 2010 on a Windows 7 machine.

I have looked at the references and there are none that are missing or flagged as a problem. I have searched all over the EE and cannot find the solution.

Any help would be greatly appreciated.

Thanks,
KLB
CPKGDevTeamAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
Have you performed maintenance on the database? If not, make a backup and then do this:

1. Compact the database
2. Decompile the database: Create a shortcut with this as the Target:

"full path to msaccess.exe" "full path to your db" /decompile

Run that to decompile
3. Compile your code. Open the VBA Editor and click Debug - Compile. fix any errors, and then continue compiling until the menitem is disabled.
4. Compact again

You might also import everything into a new, blank container.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jeffrey CoachmanMIS LiasonCommented:
(on the line for strPartNum = Me.Pt_IDN):
Compile Error:
Method or data member not found

Also be sure to check your spelling
it might be:
me.Pt_ID
me.Pt-IDN
...etc

When you type:  Me.
...Intellesense in vba should drop down a list of all the currently available member objects.

Every once in a while I get this issue as well,
Since this error will show itself rather quickly, I do all the things LSM mentioned above, and just recreate the form.

JeffCoachman
0
CPKGDevTeamAuthor Commented:
Hi Jeff and LSM:

I took all of your advice, I ran a double check for syntax. All is correct, and the same accdb file is working as expected on my Windows 7 machine.

Also, created a brand new shell and pulled in the tables, forms, etc. Then I decompiled from the command prompt.

Finally, I went into the Visual Basic editor and I compiled from the Debug menu and there were no errors this time.

The application still fails on the Windows 8 instance, but works on the rest. I have a feeling that this is completely reference related. Any ideas where I can go from here?

The error I get is back to this from my original post
:
Microsoft Visual Basic

Run-time error '-2147417848 (80010108):
Method 'RowSource' of object '_ListBox' failed


Thanks for your input,
KLB
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

Jeffrey CoachmanMIS LiasonCommented:
Copy the rowsource into a blank query and run it, ...just to see what happens

Post the rowsource here as well
0
CPKGDevTeamAuthor Commented:
This is a form that opens as an Event Procedure bu code. Here is the code:

Private Sub cmdUhOhDetail_Click()

    DoCmd.OpenForm "frm_PO_Rcpt_Time_Elapsed_Detail", acNormal
    Forms!frm_PO_Rcpt_Time_Elapsed_Detail!lstDetail.RowSource = fNR_Rcvd_Detail_Base & _
        "WHERE (((tmptbl_PO_Rcpt_Hours_Elapsed.HoursElapsed)>72)) " & _
        "ORDER BY qry_PO_Rcpt_Time_Elapsed.PO_Dte_Rcvd;"

End Sub

Open in new window


This code works just fine on Windows 7 and Windows XP. This new Windows 8 machine refuses to play well with this code. I have double checked the references that have in my own copy on Windows 7; and all the references match and there are none missing.

Thanks for any insight,
KLB
0
Jeffrey CoachmanMIS LiasonCommented:
First throw this up in a messagebox, just to view the complete SQL string:
msgbox fNR_Rcvd_Detail_Base & _
        "WHERE (((tmptbl_PO_Rcpt_Hours_Elapsed.HoursElapsed)>72)) " & _
        "ORDER BY qry_PO_Rcpt_Time_Elapsed.PO_Dte_Rcvd;"

(I am not sure, but you may need the double quotes around that leading variable...?)

But again, try sending this string out to a textbox (or to the immediate window), ...then copy it and save it as a query and run it on the troublesome machine...
Does it work?
Yes or No?

Then try ditching the Line continuation characters and try:
Forms!frm_PO_Rcpt_Time_Elapsed_Detail!lstDetail.RowSource = fNR_Rcvd_Detail_Base & " WHERE (((tmptbl_PO_Rcpt_Hours_Elapsed.HoursElapsed)>72)) " & " ORDER BY qry_PO_Rcpt_Time_Elapsed.PO_Dte_Rcvd;"

Finally, what are the actual names of these objects in the database window/Navigation pane...?
Sometimes VBA will substitute an underscore for an illegal character, ...causing confusion
0
CPKGDevTeamAuthor Commented:
Hi Boag:

I apologize for not replying sooner as our office has been in the middle of a huge vendor implementation.

I will be at work this weekend and I will be working on your suggestion above then.

Thank you for your patience and mostly for all your help.

Sincerely,
Kandice
0
Jeffrey CoachmanMIS LiasonCommented:
OK
0
CPKGDevTeamAuthor Commented:
The actual issue was with the installation of the software. I am not sure if this is because it is a tablet running Windows 8 and then installation was done over the network on a wireless connection. I never received errors on the installation, but that is my guess.

After re-install I would get an OLE error that installation would not resolve. I would receive this OLE error after I would import everything into a new container. (This was your part of the solution that led me to the next steps that did work).

Frustrated, I decided to try out the 2013 version of Access that was pre-installed on the tablet when purchased. I ran the update for Access 2013, dropped in the original accdb file and the application ran immediately and without issues.

It is not ideal to run 2 versions of Access in our environment, but since there will only be 1 tablet in the organization, for now, this extra purchase seems a better use of resources than fighting a consistently flaky install.

Thank you for your patience and your help with this issue. I apologize that I could not try to resolve and answer before today. Until yesterday, every other available moment has been dedicated to a client SAP upgrade. *shivers*

Thanks again,
KLB
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Access

From novice to tech pro — start learning today.