Security Group not coming in Alert in SharePoint 2013?

Hi, I have created one security group with email enabled in AD, I am able to add this security group in SharePoint 2007 and SharePoint 2010 library and list alert but in SharePoint 2013 library and list alert not able to add this security group while in SharePoint permission group I can add Security group.

Please guide me why in SharePoint 2013 alert not able to add Security group?
LVL 10
Minesh ShahSharePoint & all about itAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rainer JeschorCommented:
Hi,
it seems that there is an issue either built-in or with the latest Cumulative Update.
Whereas I normally do not recommend to edit SharePoint files directly, you could try to change the file
SubNew.aspx
in the SharePoint folder:
C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\TEMPLATE\LAYOUTS
the control
<wssawc:ClientPeoplePicker

Open in new window

from
SelectionSet="User,SecGroup"

Open in new window

to
PrincipalAccountType="User,SecGroup"

Open in new window


Reference link:
Blog entry

HTH
Rainer
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LibranDragonCommented:
Is the group a Global Mail enabled Security group or Universal Mail enabled Security group?
0
Minesh ShahSharePoint & all about itAuthor Commented:
Hi, I followed the steps as per above steps now able to add security group in alert.
But problem is when I adding security group in alert then users getting mails that “An alert for 'library' has been created” but when uploading/ deleting the files then no mails are coming.

Meanwhile if I adding individual user id instead of adding Security Group in alert then user getting mails for file uploading or deleting mails also.

Kindly guide
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

Rainer JeschorCommented:
Hi,
OK, the difference is, that when you add someone to get an alert, this mail is sent from the SharePoint frontend server / application pool (the subscription / setup mail).
The alerts for the events are sent through the Windows SharePoint timer service.
Which mail server are you using?
If its Exchange, can you please check this property
RequiresSenderAuthenticationEnabled
in AD / Exchange for your security group and set it to false as the alerts are sent "anonymously".

HTH
Rainer
0
Minesh ShahSharePoint & all about itAuthor Commented:
Dear Rainer, sorry for my previous reply, actually mails are coming now i just forgot to give access to that security group in the site.
After giving permission now users are getting mails.
thansks
0
Minesh ShahSharePoint & all about itAuthor Commented:
tx it's working
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.