• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 544
  • Last Modified:

Enter parameter value when running a report

I have a main report with three subreports.  When I run the report from a command button on a form I get "Enter parameter value" three times.  The queries under each subreport run fine.  No errors.  But the three subreports, even when run by themselves, give me the error.

I've looked for hidden text fields but can't find any.

1 Solution
Check in the reports'/subreports' sorting and grouping as well as the recordsource.

If the fields are inadvertently  in sorting and grouping, you will get parameter prompts.
SteveL13Author Commented:
I hate it when it's the most obvious.  Yes, I had a field in sorting and grouping for all three subreports.  Removed them because I don't need any sorting or grouping and all is well.

I should be more careful when I copy reports to make new reports.


Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now