Public Folder content sitting in message queue on Exchange 2010

Over the weekend I completed for the most part a migration from single Exchange 2003 to a single Exchange 2010.  All mailboxes have been moved and public folders replicated.  Email is flowing to and from our domain and OWA is working.  The problem I seem to be getting is if I disable the SMTP protocol on the exchange 2003 server than I start getting messages backing up in the queue on the Exchange 2010 server.  The messages are related to public folders it appears as normal smtp traffic still flows just fine.
The error is:   451 4.4.0 primary target IP address responded with "421.4.4.2 unable to connect."attempted failover to alternate host, but that did not succeed.Either there are no alternate hosts, or delivery failed to all alternate hosts.
The From address is showing as my 2010 Public folder database, Message Source is Local, Subject is Folder Content.
I have not yet moved the Public Folder replica as I want to make sure all works before moving. If I re-enable the SMTP protocol on 2003 than messages clear queue.  If I look at the recipient Info of one of the messages it is showing as my
Who is Participating?
I QasmiConnect With a Mentor Commented:
Yes those are public folder replication content mails

If you have set the replication between the exchange 2k3 and exchange 2010 it will continue unless and until you plan to demote the legacy exchange and transfer the public folder content to be generated on Exchange 2010.

have a look at this article :

moving public folder from exchange 2k3 to 2k10
joeyj1970Author Commented:
So since the replication has already taken place, I should now move all public folder replicas?
And once that is done, then there should be no more of those messages in the queue after I disable SMTP again?
I QasmiCommented:
yes thats correct

but you need to remove the legacy server from replication

and run some commands in exchange 2010 powershell

refer to the article i mentioned
joeyj1970Author Commented:
That looks as if it will solve the problem, I just need to be patient and let the move replica complete.  Thanks
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.