Citrix Presentation Server 4.5, terminal server connection doesn't disconnect after closing app

Posted on 2013-10-14
Medium Priority
Last Modified: 2013-10-26
Citrix Presentation Server 4.5

We close application and the terminal server connection for the user doesn't disconnect after closing app.  They aren't able to re-enter the application until manually disconnecting the TS session.  We have idle session limit set to 1min.  End a disconnected session at 1min.
Question by:emjay180
LVL 26

Assisted Solution

by:Sekar Chinnakannu
Sekar Chinnakannu earned 501 total points
ID: 39572776
therer may be a confilict between local settings and group policy settings. check and make sure that group policy has been applied

Assisted Solution

by:Jayanta Sarmah
Jayanta Sarmah earned 501 total points
ID: 39573002
As SekarC already suggested group policy , along with that make sure local server settings ( terminal server settings for timeout ) and also Antivirus software locking user session thread . after disconnection most of the time it is found that Antivirus exclusions are not implemented causing these kind of issues . Hope you are using Edgesight monitoring , if yes then look for the process you need to exclude from AV.

Hope this helps ...
LVL 19

Assisted Solution

basraj earned 498 total points
ID: 39574256
I did had similar issues. In my case i tried all these to fix the problem. Some application do not have log-off feature so they still run in the background as active sessions.

1. I followed the Symantec article to prevent all Citrix process (it's available online). Similarly if you have any other antivirus running, make sure exclusions are made
2. Parity process was running, had to stop it.
3. The other imporatant thing is that i found some processes were still running in the background. Had to add some process to th Wshell\TWi registry key as shown in the resolution section of the following article:


Accepted Solution

emjay180 earned 0 total points
ID: 39589456
I had already uninstalled AV, it worked with previous releases so I didn't feel it needed the manual TWI reg key additions, seems like it was something weird in the citrix receiver.  We did a fresh install of that and everything closed the way it did before.  Thank you all for your suggestions.

Author Closing Comment

ID: 39602438
These were all valid reasons and similar.

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

#Citrix #Citrix Netscaler #HTTP Compression #Load Balance
While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses

587 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question