IIS setup on Windows 7 for dotnet app

Hi Experts. I'm trying to run my dotnet web app locally on IIS/Windows 7. I've only just installed IIS 6.1 on it.

The application runs fine from visual studio in Internet Explorer but when I publish it to my inetpub/WWW directory it throws this error...

--------------------------
 Compilation Error
Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: BC30002: Type 'BFGlobal.APIRequestHeader' is not defined.

--------------------------

I presumed this is some kind of permissions issue but I've opened up all of the security in the WWW directory as far as possible.

The application also seems to have difficulty working out where the relevant files are. E.g. it doesn't seem to be looking in the BIN directory for the executable so perhaps its my webconfig/publish settings that are at fault?

Thanks for you help!
LVL 7
Clever_BobAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ShareD_PointCommented:
Hi,

Aren't you using qualified namespaces in your program. Is there any conflict in class name because of lack of fully qualified namespace.
What is BFGlobal in your application contest.

There is also a possibility of the Application using an older version of the Dll.  Try to update the dll reference. (delete and add again).
OR
The older Dll might have got cached. Clear the V.Net cache folder / your Application's cache.

Rebuild and publish the application.


Believe you are using IIS 7.5 (To best my knowledge there isn't any IIS 6.1)

Hope this may helps.
0
Clever_BobAuthor Commented:
Hey, thanks for the reply.

- Namespaces: This is the line of code in question. BFGlobal is registered in the references section but as I say it works fine in debug mode (i.e. run from Vis Studio) so I doubt this is the issue?

Dim oHeaderGL As New BFGlobal.APIRequestHeader



- DLL. Hasn't been updated for years. I have just looked into clearing the cache but I can't get into my Documents and Settings (access Denied), perhaps this is part of the problem!

- Have rebuilt/republished a dozen times trying different things. No joy

- You're right, its IIS 7.5 sorry!
0
ShareD_PointCommented:
Hi,

Did you enable enable32BitAppOnWin64 property in Application Pool Defaults. Set this to true.

You may have 32 bit Dlls which can not load under a 64-bit application pool.

Hope this may Helps.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

Clever_BobAuthor Commented:
You're right, it was set to false. I've changed the setting and restarted IIS but still the same error I'm afraid.
0
ShareD_PointCommented:
Check in task manager - process tab, you are able see "w3wp.exe * 32", other wise settings are not accepted.

Open "applicationHost.config" of the machine and check what is the entry corresponding to your application pool's Enable32BitAppOnWin64 property, if it is still false , set it to true.

Reset IIS ( use Admin Console) and re - register the dll.
0
Clever_BobAuthor Commented:
Yeah there is no 'w3wp.exe' process running.

I don't seem to have an applicationHost.config file at all, where should it be??
0
Clever_BobAuthor Commented:
Perhaps its a problem with the framework I'm targetting. The versions seem to be all over the place. The references in Visual Studio mostly say .Net version 2.0.0.0 (although some are 3.5) but the  web.config mostly references 4.0 and the IIS framework is 4.0.
0
ShareD_PointCommented:
From the tasks manager's processes tab, "Show Process from all users" may need to be checked / clicked in order to see the w3wp process. The worker processes may be running under a different user account.

ApplicationHost.config file is located in %windir%\system32\inetsrv\config
0
Clever_BobAuthor Commented:
Definitely no process called w3wp running under any user.

Found the application config thanks. enable32BitAppOnWin64="true"
0
ShareD_PointCommented:
/*
The application also seems to have difficulty working out where the relevant files are. E.g. it doesn't seem to be looking in the BIN directory for the executable so perhaps its my webconfig/publish settings that are at fault?

*/

Check weather your virtual directory is pointing to correct location. There is a chance of wrong mapping of physical folders with virtual directory.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Clever_BobAuthor Commented:
great idea! Yes that worked fine and when I created the app from scratch everything was resolved. Very strange. Thanks for all your suggestions!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.