Creating Vfat File System Failed upgrading to ESXi 5.1

Server is an HP DL380 G6 with 3 current W2K8 servers.  The array was successfully expanded giving us 800GB free.  Battery Cache was replaced and HP bundle applied to the ESXi 4.1.  Technicians have tried twice and been unsuccessful.  Disconnected the keyboard after the first try thinking that might have been the issue.  the following is from the Tech:

Attempting to upgrade from ESXi 4.x to ESXi 5.x and facing the error attached.  There are two partitions, one of which has ESXi on it with the other being a secondary partition from when an array was expanded.  Server hardware should be compatible as we’re using similar with ESXi 5.x at alternate sites.  Its an HP server and attempted to update with both the VMWare default 5.x bootable ISO as well as the HP VMWare bootbal ISO and received same error when using either upgrade process.  Main purpose is to save existing VMWare guest servers, which are on the same disk partition as ESXi 4 while performing the upgrade.
ESXi Error
LVL 17
pjamAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Seth SimmonsSr. Systems AdministratorCommented:
have you seen this article?

Upgrading from ESXi 4.x to 5.x fails with error: Invalid argument when creating vfat file system (2015828)

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2015828
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Do not try and complete an update.

Complete a fresh new installation.

and I would recommend, install the ESXi OS on a USB or SD card, to separate the ESXi OS from the datastore.

Your G6 has an internal USB socket for this very purpose.


Here is the VMware KB on installing 5.0 on USB/SD:
http://kb.vmware.com/kb/2004784

Also use the HP OEM version as well.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pjamAuthor Commented:
Seth,
The Tech had seen that KB and determined it unacceptable for this situation.

Hanccocka,
We are ordering an SD card at this moment, is 4GB big enough?
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Yes, plenty big enough 1GB is the minimum size!
0
pjamAuthor Commented:
Update:
4GB SDHC memory installed last night on motherboard and appears that it can be used.  Will start as soon as backups Of VMs are finished.
0
pjamAuthor Commented:
Everything went well installing into the 4GB SDHC memory card.
Thanks hanccocka, once again
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.