Exchange 2007 email not received by external domains - internally it works

This problem started today without system configuration changes.  User are not able to receive emails from any external domain.  There are not error messages rec’d by the sender.  User can successfully send emails to all external addresses without error.  Emails are not received on Outlook client or owa.
I’m not sure if this is related to the pressure back issue or not.
I would appreciate any assistance on this matter since it’s been down all day.  (Note:  I’m new to Exchange and not very familiar with any version beyond setup users)
Problem:
No external email is being received.  External senders are not receiving any delivery errors.  Internal mail works and we can send externally.
Troubleshooting steps:
1.       Rebooted the exchange server – no resolve.
2.      Ran the Exchange Toolkit
•      Received error   - Mail submission failed.  Error message: Service not available, closing transmission channel.  The server response was: 4.3.2 Service not available, closing transmission channel.
•      Sender ID accepts failed messages: Sender ID filtering is set to accept messages that fail the Sender ID validation test
•      I received the test mail from the troubleshooting assistant: ExMFA-MailAcceptTest@Fabrikam.com
3.       I attempted to telnet but received the same server response error:  421 4.3.2 Service not available, closing transmission channel.
4.      I ran the Microsoft Connectivity Analyzer and received a message  (only warning included):  Connectivity Successful with Warnings.
       Analyzing SMTP Capabilities for server housecalldoctorstexas.com.inbound15.mxlogicmx.net:25
       The test passed with some warnings encountered. Please expand the additional details.
              Additional Details
       Unabled to determine SMTP capabilities. Reason: Authentication failed to the SMTP server.
Elapsed Time: 97 ms.

       Analyzing SMTP Capabilities for server housecalldoctorstexas.com.inbound15.mxlogic.net:25
       The test passed with some warnings encountered. Please expand the additional details.
              Additional Details
       Unabled to determine SMTP capabilities. Reason: Authentication failed to the SMTP server.
Elapsed Time: 85 ms.
HCD01Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

R_EdwardsCommented:
Do a Netstat -a. Does it show port 25 as listening
0
HCD01Author Commented:
Thanks for responding R_Edwards.  I was able to resolve this issue yesterday.  There were several issues but the main one was our firewall was routing all mail to a security provider and our service had expired with them (but know one knew the firewall logon or the service provider).  After gaining access to the firewall I was able to redirect the mail traffic.

Thanks again,
Dexter
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
HCD01Author Commented:
I was able to resolve the issue by redirecting our mail traffic on our firewall
0
R_EdwardsCommented:
Awesome! glad you found a fix!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Applications

From novice to tech pro — start learning today.