Windows 7 64bit Acer Laptop not loading USB device drivers

I now have two Laptop units both same model (started with just one, around the beginning of October, Acer Travelmate 7530), that even though Windows states the drivers is loaded and device ready for use, such as USB Mouse, it does not work. When I check device manager, I have an Unknown listed for the device with Code 28.  This happens with three different USB devices, ones I can plug into other units and they load with no issue. One device is USB Microsoft mouse.

I can not figure out why this is happening, especially after the second one starting doing it just last week apparently after Windows updates, and I do feel Windows Updates are related to the issue. I tried system restore on first Laptop along with coping USBport.inf and USBStor.*  files from backups.I've tried uninstalling the USB universal USB device controller and rebooting but with same issue. Also I've already tried installing the Chipset drivers from Acer again with no change.

Any ideas anyone?  from my online research, seems a lot have had this issue, some where able to resolve, others not so luck.
Neil-s-USB-issue-snapshot.PNG
CATHY-ITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Nick RhodeIT DirectorCommented:
You do have the latest chipset drivers installed correct?
0
nobusCommented:
try updating all your drivers :  http://us.acer.com/ac/en/US/content/drivers
you can also test if the problem is hardware or soft, by running from a live linux cd - here a Knoppix one : ftp://mirrors.kernel.org/knoppix-dvd/KNOPPIX_V7.0.5DVD-2012-12-21-EN.iso 

if the usb works fine then - the problem is clearly software, and can be solved by installing drivers or the OS

if not, you have a bad motherboard

since it started from october - i have seen a lot of problems with windows october updates
example :  http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_update/1082013-windows-update-has-jacked-my-pc/27dbff1d-1a10-423e-b9f5-9ca029f364cc

more :  http://pcsupport.about.com/b/2013/10/08/patch-tuesday.htm
0
CATHY-ITAuthor Commented:
Taking a look at the links you sent and I did uninstall KB2862330, that didn't make any difference. Looking into more current Chipset drivers, but I had already installed the ones provided by Acer.ca, (Canada).  Keep you posted as soon as I looking to this further, thank you for you input thus far
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

nobusCommented:
ok  - post results
0
CATHY-ITAuthor Commented:
Again, sorry about delay.. One Person Tech Dept here.  Results at this moment are that the first Laptop is needed back in the field, so I wiped and I'm re-installing Win 7. and even as I started the install USB Mouse works just fine

 But I'm also using it as my comparison. Noticed that malfunctioning one is trying to load drivers with that are different version than on the freshly wiped.. trying to get malfunction back to using the older drivers, but very time consuming to figure it out.... if I do I'll let you know

I've tried what has been suggested with no luck there.. anything else you might think of let me know otherwise, I may just have to wipe.
0
nobusCommented:
did you run a live cd - wand what was the result?  >>  I've tried what has been suggested with no luck there << does not tell me a thing
0
CATHY-ITAuthor Commented:
Problem has been resolved, but I still not 100% exact on the cause (annoyed). I ended up making a Windows 7 Sp1 DVD from my TechNet subscription and Ran the Upgrade option to essentially re-install Windows 7 sp1 right on top of the current installation without losing any data. It then had to re-install some windows updates there after. so far the USB ports have been working fine as I'm using the USB Mouse

As for your inquiry, I didn't run the live CD to see if the mouse worked in that mode, as I had also tried a System repair from the Boot screens and the mouse worked fine in that mode, also the probability of two units both have exact same Hardware issue seemed skim

What I did try that didn't work for my situation but apparently had worked for others in the past.

- I had tried uninstalling the Oct updates KB2862330 and KB2862335 that were referenced in the links you gave me above and pertain to USB drivers, made no difference.
- I had tried on the first malfunctioning Unit to use System Restore back to a Sept Point, made no change. The Second malfunctioning Unit unfortunately didn't have System Restore enabled properly, thus no Restore points to try.

- removing the Standard USB Controllers and Rebooting and letting Windows re-install them, no change

- looking for Upper and Lower Filter values in Registry under
HLM\System\CurrentControlSet\Control\Class\{36fc9e60-c465-11CF-8056-444553540000}, Neither of these two units had any upper or lower filter values.

-Replacing USBStor.inf and USBstor.PNF that are in Windows\inf with backup files from c:\windows\System32\Driver Store\File Repository\USBstore.inf. along with deleting the *.dat and *.1 file under c:\windows\System32\Driverstore

- I had tried manually changing the Drivers files for the USB Mouse to the same Version that the Freshly wiped and working laptop was using, but after reboot the system reverted back to newer ones that I though maybe the issue, then I also tried replacing the entire HLM\System\ControlSet001\Control\CriticalDeviceDatabase Registry folder with the Good working one from the first laptop I had just wiped, as I notice that it was pointing to older working Drive Store folder that I had tried to copy over manually, This made no change either.. then I found my solution above.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nobusCommented:
the cause can be many things : like old device installs locking the usb , os corruption
driver corruption
all of which may have been remedied by the things you did

let's hope it keeps up!
0
nobusCommented:
thanks for feedback
0
CATHY-ITAuthor Commented:
Hope I'm fair in allotting points, but I did figure the solution on my own, though Nobus you mentioned that it could be an OS issue as well and assisted in my troubleshooting path.

Thank you for input and your time

I also read that Microsoft has revised the Update for KB2862330, as it was causing various issues, and checked out the support page from MS at  http://support.microsoft.com/kb/2862330
this was revised on Oct 18th, stating the known issue.
0
nobusCommented:
tx for feedback, Cathy
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.