Corrupt NTDS SBS 2011

Hi all,

After a RAID rebuild my NTDS file is corrupt. I have tried everything

NTDS Error
As you can see here, this is the latest error.
liminalAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

liminalAuthor Commented:
OK after all the reading I have done. It looks like its well and truly pooched.

I have a back up from about 3 months ago. If I were to copy the NTDS.dit from that and paste it to the directory... Would that work?

Or should I just start rebuilding the SBS server now.

Can I save my mail (I only have one mailbox?)
0
Life1430Commented:
Check after copy paste... make sure you backup the current system state before this
Also delete all the log files in C:\windows\ntds before restarting DC once the copy paste has done
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
liminalAuthor Commented:
So your saying it would work? Because its giving my an error saying the database is inconsistent.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Life1430Commented:
Ya It would work....
0
liminalAuthor Commented:
It didnt work
0
Life1430Commented:
What was the error ...did you deleted the log files in c:\windows\ntds folder
0
liminalAuthor Commented:
I did, it just said something about data discrepancy and that it was also corrupt.

In the end I restored that backup and backed up my mail to a PST to restore... Its all working again now.

THanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.