USB Hard drive - SBS 2003

We recently purchased USB 3 hard drives for use as a backup device for an SBS 2003 server, which connects to USB 2 ports.

There are 5 drives that are replaced daily. However, when the drive is removed, then reconnected is does not regain its assigned drive. In this case F drive. When this happens, we need to access the Disk Management tool and manually assign the F drive letter to the hard drive (each time). If we do not do this, the SBS backup tool does not see the F drive which result in the destination drive being unavailable, and the backup fails.

Any ideas?
swan_solutionsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

noxchoGlobal Support CoordinatorCommented:
Is the NoAutomount in registry set to 1 or 0?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nobusCommented:
you could assign a fixed drive letter : http://www.uwe-sieber.de/usbdlm_e.html
0
swan_solutionsAuthor Commented:
Hi Noxcho,

Sorry for the late reply. This seems to be the issue. It was set to 1. We changed it to 0 and drives could get a drive letter. However, after less than a week, it turned back to 1. We're investigating whether this is reset on a reboot of the server.

Hi Nobus,
thanks for the advice, however, we've tried that, but it just refuses to get a drive letter until we change the NoAutomunt setting to 0.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

nobusCommented:
ok, but what happens if you then give a drive letter?  does it work, or not?
0
swan_solutionsAuthor Commented:
Yes, but after disconnecting the drive and reconnecting the drive, it does not get a drive latter. this must be assigned manually.

Also it happen with any USB Drive we connect. It get detected and appears in Device Manager, the Disk Management see the partitions, but does not give it a Drive letter.
0
nobusCommented:
try updating the chipset driver
0
noxchoGlobal Support CoordinatorCommented:
So the issue is NoAutoMount key value.
The problem is caused normally by third party software used to work with drives. What backup software are you using? Or is there any partitioning software installed on this server?
0
swan_solutionsAuthor Commented:
Added the next USB drive for backup and the Noautomount entry has appeared in the registry with a value of 1.

Will check again once the backup has completed and the next drive is ready to be plugged in
0
swan_solutionsAuthor Commented:
Next external USB HDD has been connected and whilst picked up in Disk Management, it does not allocate the drive letter
0
nobusCommented:
i asssume it was working OK before?
then a system restore to that period can help
0
noxchoGlobal Support CoordinatorCommented:
What backup tool is used by you? Windows backup or third party backup software?
0
swan_solutionsAuthor Commented:
We are currently using NT Backup
0
noxchoGlobal Support CoordinatorCommented:
Any other backup software installed? Normally this value is changed by non Windows application for specific purposes. So I am trying to find our which is the culprit in your case.
0
swan_solutionsAuthor Commented:
Thanks noxcho, the NoAutomount was the problem, for some unknown reason it kept resetting. When we reboot the server, it settled down.
0
noxchoGlobal Support CoordinatorCommented:
Always welcome.
Have a nice weekend!
Nox
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.