webbrowser script error with google maps

I am using a webbrowser object in my Access 2010 application (called WebMap) to display a google map to the user.  The content is dynamically updated for each customer record.  When the click the map page the object source is updated to the new address.
i.e.  Me.WebMap.ControlSource ="=http://maps.google.com/maps?q=+Stationsplein,+76,+7311+NX,+NETHERLANDS".

This has worked well for many months but Google has now changed something and I get a Script Error similar to this:
Line 720
Char 172
Error Invalid Character
Code 0
URL https://maps.google.com/mapfiles/home3.html

If I cut and paste the URL (http://maps.google.com/maps?q=+Stationsplein,+76,+7311+NX,+NETHERLANDS) in to a browser I get no error!

Has anyone got a "fix" for this?
LVL 1
Hugh CarterAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jeffrey CoachmanMIS LiasonCommented:
Get rid of the "=" in your original url perhaps:

Me.WebMap.ControlSource ="http://maps.google.com/maps?q=+Stationsplein,+76,+7311+NX,+NETHERLANDS"

Or try this syntax:
Me.WebMap.navigate "http://maps.google.com/maps?q=+Stationsplein,+76,+7311+NX,+NETHERLANDS"
0
Hugh CarterAuthor Commented:
Hi boag2000,

Thanks for the reply but this does not resolve the issue:

1. The "=" sign is required as part of the value in the Control Source...

2. The property .navigate does not exist that I can see and causes an error when I test it.

This was all working fine until about a week ago!

Regards,

Hugh
0
Jeffrey CoachmanMIS LiasonCommented:
Are you using the standard MS Activex webrowser control?
The standard MS Activex webrowser control does not have a controlsource property.

In any event, what I posted works fine for me using The standard MS Activex webrowser control...
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Dave BaldwinFixer of ProblemsCommented:
@ HHI-Admin, in your original post you had two '=' at the beginning.  

Me.WebMap.ControlSource ="=http:...

Was that a typo?
0
Hugh CarterAuthor Commented:
Hi Jeffrey (Jeff?) and Dave,

I've attached a simple app with a single form that, for me, illustrates the script error issue.

= sign - No typo.  It's required as you can see in the attached.

The control is the standard Web Browser Control selected from the normal Design Ribbon.  It's next to the Hyper-link icon and looks like a form with a little world).

I also tried the ActiveX object and used the ".navigate" property.  I get the same script error.

Thanks.

Hugh
0
Hugh CarterAuthor Commented:
File wasn't uploaded!  See here...
MapURL-Error.zip
0
Jeffrey CoachmanMIS LiasonCommented:
1.  Oh, ...that appears to be a new web browser for Access 2010
2. The link you posted originally is NOT the same as the link on the webrowser.
The link in your original post is:
"=http://maps.google.com/maps?q=+Stationsplein,+76,+7311+NX,+NETHERLANDS".

...The link in the actual webrowser is:
="http://maps.google.com/maps?q=Tiendweg,13,4142+EG,NETHERLANDS"

...In any event, both of these links work and display fine in the webrowser without issue for me...

So are you quite sure that: "Google has now changed something"?
Again, both work fine for me in Access 2010...
xy
JeffCoachman
0
Hugh CarterAuthor Commented:
Hi Jeff,

I don't seem to be alone; http://www.utteraccess.com/forum/Google-Maps-Script-Erro-t2010082.html&mode=linearplus

err
I did change the link between my original post and this sample application but the principle is the same.  Any link to a "maps" page causes the error.  Other pages work well.

I've tested this on 3 of my machines and it's been tested on 2008 R2 Server RDP session (6 times in fact as there are several users!).  All machines tested so far get the error above.  The computers are based in the Netherlands and Portugal if that makes any difference to Google.

Am I going mad?  Can anyone else replicate the error?
0
Hugh CarterAuthor Commented:
I found a way to stop the error message at utteraccess so I inserted the VBA and this does stop the error message but not the error.  The page is unresponsive so it is not possible to move around the map as one would normally be able to.
Private Sub Form_Load()
Me.WebBrowser0.Object.Silent = True
End Sub

Open in new window

If we use Bing as the map provider then everything is ok;
Control Source ="http://www.bing.com/maps/?q=Tiendweg,13,4142+EG,NETHERLANDS"
but the Google map that includes a street view etc. is much preferred by our users.
0
Jeffrey CoachmanMIS LiasonCommented:
FWIW, I was getting an error like that when I used IE asmy default browser, ...My default browser is now FireFox, ...no errors
Again...FWIW...
0
Hugh CarterAuthor Commented:
OK guys.  The problem has rectified itself which sort of confirms to me that it was a Google issue all along.

Thanks for your time in looking at this with me.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Hugh CarterAuthor Commented:
No solution was correct as problem seems to have been Google's all along!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.