"Access Denied" when try to modify Google Earth Flight Sim F-16 parameter file

Hello,

I found a YouTube video with instructions re how to modify the Max velocity (x 10 apparently) for the F-16 in Google Earth's Flight Simulator. The video is located here:

    http://www.youtube.com/watch?v=n1ZRMJAY9nM 

The video said to go to the following directory:

    C:\Program Files\Google\Google Earth\res\flightsim\aircraft

and open the file "f16.acf" with Notepad. The the posting date for the video is 2008 and I am running Windows 7 (and Google Earth 7.1.1.1871) so I assume that time difference explains the slight difference in my directory:

    C:\Program Files (x86)\Google\Google Earth\client\res\flightsim\aircraft\f16.acf

The steps in the video are straightforward and involve changing four parameters:

    V_approach = 130    —>    change to 400
    V_cruise = 330    —>    change to 1000
    P_max = 130e7    —>    change to 60e9
    F_max = 130e3    —>    change to 200e5

After making the changes, the next step was to save the file as a replacement for f16.acf in the original directory. At first, I inadvertently attempted to save it as a .txt file and got an alert saying "Access Denied". However, even when I tried saving it in several different ways, eg:

    • Save as type: All Files
    • f16.acf
    • C:\Program Files (x86)\Google\Google Earth\client\res\flightsim\aircraft\f16.acf

I always ended up with the "Access Denied" notice.

I saw nothing in the video mentioning this obstacle so if someone could explain how to get past it, I would appreciate it.

Thanks
Steve_BradyAsked:
Who is Participating?
 
Spyder2010Connect With a Mentor Commented:
I have gotten past this issue by:

Copy the file in question to your desktop.
Open the copied(desktop) file, make your changes.  Save this file to your desktop.
Rename the original file.
Copy the file from your desktop to the location of the original file.

Why this works doesn't make sense to me, but it's helped me get around the UAC on Win7 machines... they sometimes are picky about what files on the system drive you can edit.
0
 
Joe Winograd, Fellow&MVEConnect With a Mentor DeveloperCommented:
Hi Steve,
Spyder2010's technique should work. Of course, you don't have to copy the file to your desktop...you may copy it anywhere you want, modify it, and then copy it back. When you do, you'll likely still get an Access Denied message on the copy, but you'll have a button that says [As Administrator]...click that and the copy will work (assuming, of course, that you have admin rights). A second technique is to run Notepad with admin privileges. To do this, right-click on the Notepad shortcut and select [Run as administrator]. You'll get the standard UAC dialog...click the Yes button. Then you can do a File>Open of the file in Notepad (or drag-and-drop it), make the changes, and then when you do the save, it will work immediately. Regards, Joe
0
 
Steve_BradyAuthor Commented:
Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.