Cannot Restart MySql server.

I'm having difficutlies getting my MySql server back online and running and I need assistance on how to get it back. I have limited knowledge and experience with Linus server administration but I am a pretty quick learner, so please be clear and concise in your feedback / suggestions.

Here is what I know about the server. It is a Gentoo installation of Linux, Apache is running, but not MySql. I've checked "/etc/mysql/my.cnf" and from what I can tell, all appears normal, I currently have bind-address set to 127.0.0.1 (I've tried just localhost too with same results).

Every time I try to start mysql, here is what happens:
tarp ~ # sudo /etc/init.d/mysql restart
 * Starting mysql ...
 * Starting mysql (/etc/mysql/my.cnf)
 * MySQL NOT started (1)  


Also, on my website this is the error message being displayed:

Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

I don't know what else to check, the apparent error logs for mysql are either not present or are empty. Please help, if you need more information I will try and get it for you, please give commands on how to retrieve the information. Thank you in advance for your help!
id4382Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

junipllcCommented:
Does your my.cnf have any mention of error logs? If not, put this into your my.conf under the [mysqld]:

log_error = /tmp/mysql-error.log

Open in new window

That should put an error log in your /tmp directory (I chose this because the permissions will allow it). Then, after you try to start the MySQL server again, check that file:

more /tmp/=mysql-error.log

Open in new window

and see if anything exists in there that makes sense. Post anything back in here that you find and we can probably figure it out.

Cheers

Mike
0
junipllcCommented:
grrr..... it should read:

more /tmp/mysql-error.log

Open in new window

0
id4382Author Commented:
After making the changes, tried starting, restarting...nothing appears in the folder. Here is the my.cnf file:

 /etc/mysql/my.cnf: The global mysql configuration file.
# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/files/my.cnf-4.1,v 1.4 2008/11/14 02:16:25 robbat2 Exp $

# The following options will be passed to all MySQL clients
[client]
#password                                       = your_password
port                                            = 3306
socket                                          = /var/run/mysqld/mysqld.sock

[mysql]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[mysqladmin]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[mysqlcheck]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[mysqldump]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[mysqlimport]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[mysqlshow]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[myisamchk]
character-sets-dir=/usr/share/mysql/charsets

[myisampack]
character-sets-dir=/usr/share/mysql/charsets

# use [safe_mysqld] with mysql-3
[mysqld_safe]
err-log                                         = /var/log/mysql/mysql.err
l
# add a section [mysqld-4.1] or [mysqld-5.0] for specific configurations
[mysqld]
log_error = /tmp/mysql-error.log
character-set-server            = utf8
default-character-set           = utf8
user                                            = user
port                                            = 3306
socket                                          = /var/run/mysqld/mysqld.sock
pid-file                                        = /var/run/mysqld/mysqld.pid
log-error                                       = /tmp/mysql-error.log
basedir                                         = /usr
datadir                                         = /var/lib/mysql
skip-locking
key_buffer                                      = 16M
max_allowed_packet                      = 1M
key_buffer                                      = 16M
max_allowed_packet                      = 1M
table_cache                             = 64
sort_buffer_size                        = 512K
net_buffer_length                       = 8K
read_buffer_size                        = 256K
read_rnd_buffer_size            = 512K
myisam_sort_buffer_size         = 8M
language                                        = /usr/share/mysql/english

# security:
# using "localhost" in connects uses sockets by default
# skip-networking
bind-address                            = 127.0.0.1

log-bin
server-id                                       = 1

# point the following paths to different dedicated disks
tmpdir                                          = /tmp/
#log-update                             = /path-to-dedicated-directory/hostname

# you need the debug USE flag enabled to use the following directives,
# if needed, uncomment them, start the server and issue
# #tail -f /tmp/mysqld.sql /tmp/mysqld.trace
# this will show you *exactly* what's happening in your server ;)

#log                                            = /tmp/mysqld.sql
#gdb
#debug                                          = d:t:i:o,/tmp/mysqld.trace
#one-thread

# uncomment the following directives if you are using BDB tables
#bdb_cache_size                         = 4M
#bdb_max_lock                           = 10000

# the following is the InnoDB configuration
# if you wish to disable innodb instead
# uncomment just the next line
#skip-innodb
#
# the rest of the innodb config follows:
# don't eat too much memory, we're trying to be safe on 64Mb boxes
# you might want to bump this up a bit on boxes with more RAM
innodb_buffer_pool_size = 16M
# this is the default, increase it if you have lots of tables
innodb_additional_mem_pool_size = 2M
#
# i'd like to use /var/lib/mysql/innodb, but that is seen as a database :-(
# and upstream wants things to be under /var/lib/mysql/, so that's the route
# we have to take for the moment
#innodb_data_home_dir           = /var/lib/mysql/
#innodb_log_arch_dir            = /var/lib/mysql/
#innodb_log_group_home_dir      = /var/lib/mysql/
# you may wish to change this size to be more suitable for your system
# the max is there to avoid run-away growth on your machine
innodb_data_file_path = ibdata1:10M:autoextend:max:128M
# we keep this at around 25% of of innodb_buffer_pool_size
max_allowed_packet                      = 1M
table_cache                             = 64
sort_buffer_size                        = 512K
net_buffer_length                       = 8K
read_buffer_size                        = 256K
read_rnd_buffer_size            = 512K
myisam_sort_buffer_size         = 8M
language                                        = /usr/share/mysql/english

# security:
# using "localhost" in connects uses sockets by default
# skip-networking
bind-address                            = 127.0.0.1

log-bin
server-id                                       = 1

# point the following paths to different dedicated disks
tmpdir                                          = /tmp/
#log-update                             = /path-to-dedicated-directory/hostname

# you need the debug USE flag enabled to use the following directives,
# if needed, uncomment them, start the server and issue
# #tail -f /tmp/mysqld.sql /tmp/mysqld.trace
# this will show you *exactly* what's happening in your server ;)

#log                                            = /tmp/mysqld.sql
#gdb
#debug                                          = d:t:i:o,/tmp/mysqld.trace
#one-thread

# uncomment the following directives if you are using BDB tables
#bdb_cache_size                         = 4M
#bdb_max_lock                           = 10000

# the following is the InnoDB configuration
# if you wish to disable innodb instead
# uncomment just the next line
#skip-innodb
# 
# the rest of the innodb config follows:
# don't eat too much memory, we're trying to be safe on 64Mb boxes
# you might want to bump this up a bit on boxes with more RAM
innodb_buffer_pool_size = 16M
# this is the default, increase it if you have lots of tables
innodb_additional_mem_pool_size = 2M
# 
# i'd like to use /var/lib/mysql/innodb, but that is seen as a database :-(
# and upstream wants things to be under /var/lib/mysql/, so that's the route
# we have to take for the moment
#innodb_data_home_dir           = /var/lib/mysql/
#innodb_log_arch_dir            = /var/lib/mysql/
#innodb_log_group_home_dir      = /var/lib/mysql/
# you may wish to change this size to be more suitable for your system
# the max is there to avoid run-away growth on your machine
innodb_data_file_path = ibdata1:10M:autoextend:max:128M
# we keep this at around 25% of of innodb_buffer_pool_size# /etc/mysql/my.cnf: The global mysql configuration file.
# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/files/my.cnf-4.1,v 1.4 2008/11/14 02:16:25 robbat2 Exp $
innodb_data_file_path = ibdata1:10M:autoextend:max:128M
# we keep this at around 25% of of innodb_buffer_pool_size
# sensible values range from 1MB to (1/innodb_log_files_in_group*innodb_buffer_pool_size)
innodb_log_file_size = 5M
# this is the default, increase it if you have very large transactions going on
innodb_log_buffer_size = 8M
# this is the default and won't hurt you
# you shouldn't need to tweak it
set-variable = innodb_log_files_in_group=2
# see the innodb config docs, the other options are not always safe
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50
innodb_file_per_table
innodb_force_recovery = 8

[mysqldump]
quick
max_allowed_packet                      = 16M

[mysql]
# uncomment the next directive if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer                                      = 20M
sort_buffer_size                        = 20M
read_buffer                             = 2M
write_buffer                            = 2M

[myisamchk]
key_buffer                                      = 20M
sort_buffer_size                        = 20M
read_buffer                             = 2M
write_buffer                            = 2M

[mysqlhotcopy]
interactive-timeout

Open in new window

0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

junipllcCommented:
Can you take a look in this file: /var/log/mysql/mysql.err ? The error log may exist in there.
0
id4382Author Commented:
Ok, so we have a mysql.err, mysql.log and a mysqld.err; mysqld.err is the jackpot.

Here is what it says:

090911  8:53:05 [Warning] No argument was provided to --log-bin, and --log-bin-index was not used; so replication may break when this MySQL server acts as a master and has his hostname changed!! Please u$
090911  8:53:06 [Warning] No argument was provided to --log-bin, and --log-bin-index was not used; so replication may break when this MySQL server acts as a master and has his hostname changed!! Please u$
090911  8:53:10 [Warning] No argument was provided to --log-bin, and --log-bin-index was not used; so replication may break when this MySQL server acts as a master and has his hostname changed!! Please u$
InnoDB: The first specified data file ./ibdata1 did not exist:
InnoDB: a new database to be created!
090911  8:53:10  InnoDB: Setting file ./ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
090911  8:53:11  InnoDB: Log file ./ib_logfile0 did not exist: new to be created
InnoDB: Setting log file ./ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
090911  8:53:11  InnoDB: Log file ./ib_logfile1 did not exist: new to be created
InnoDB: Setting log file ./ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
090911  8:53:11  InnoDB: Started; log sequence number 0 0
090911  8:53:11 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.0.70-log'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  Gentoo Linux mysql-5.0.70-r1
131012 22:41:09 [ERROR] /usr/sbin/mysqld: Disk is full writing './mysqld-bin.000004' (Errcode: 28). Waiting for someone to free space... Retry in 60 secs
131012 22:51:09 [ERROR] /usr/sbin/mysqld: Disk is full writing './mysqld-bin.000004' (Errcode: 28). Waiting for someone to free space... Retry in 60 secs
131012 23:01:09 [ERROR] /usr/sbin/mysqld: Disk is full writing './mysqld-bin.000004' (Errcode: 28). Waiting for someone to free space... Retry in 60 secs
131012 23:11:09 [ERROR] /usr/sbin/mysqld: Disk is full writing './mysqld-bin.000004' (Errcode: 28). Waiting for someone to free space... Retry in 60 secs
131012 23:21:09 [ERROR] /usr/sbin/mysqld: Disk is full writing './mysqld-bin.000004' (Errcode: 28). Waiting for someone to free space... Retry in 60 secs
131012 23:31:09 [ERROR] /usr/sbin/mysqld: Disk is full writing './mysqld-bin.000004' (Errcode: 28). Waiting for someone to free space... Retry in 60 secs
131012 23:41:09 [ERROR] /usr/sbin/mysqld: Disk is full writing './mysqld-bin.000004' (Errcode: 28). Waiting for someone to free space... Retry in 60 secs
131012 23:51:09 [ERROR] /usr/sbin/mysqld: Disk is full writing './mysqld-bin.000004' (Errcode: 28). Waiting for someone to free space... Retry in 60 secs
131013  0:01:09 [ERROR] /usr/sbin/mysqld: Disk is full writing './mysqld-bin.000004' (Errcode: 28). Waiting for someone to free space... Retry in 60 secs
131013  0:11:09 [ERROR] /usr/sbin/mysqld: Disk is full writing './mysqld-bin.000004' (Errcode: 28). Waiting for someone to free space... Retry in 60 secs
131013  0:21:09 [ERROR] /usr/sbin/mysqld: Disk is full writing './mysqld-bin.000004' (Errcode: 28). Waiting for someone to free space... Retry in 60 secs
131013  0:31:09 [ERROR] /usr/sbin/mysqld: Disk is full writing './mysqld-bin.000004' (Errcode: 28). Waiting for someone to free space... Retry in 60 secs
131013  0:41:09 [ERROR] /usr/sbin/mysqld: Disk is full writing './mysqld-bin.000004' (Errcode: 28). Waiting for someone to free space... Retry in 60 secs
131013  0:51:09 [ERROR] /usr/sbin/mysqld: Disk is full writing './mysqld-bin.000004' (Errcode: 28). Waiting for someone to free space... Retry in 60 secs
131013  1:01:09 [ERROR] /usr/sbin/mysqld: Disk is full writing './mysqld-bin.000004' (Errcode: 28). Waiting for someone to free space... Retry in 60 secs
131013  1131014 09:48:05  mysqld started
nohup: ignoring input
131014  9:48:05 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
131014  9:48:05 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
131014  9:48:05 [Warning] No argument was provided to --log-bin, and --log-bin-index was not used; so replication may break when this MySQL server acts as a master and has his hostname changed!! Please u$
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
131014  9:48:05  InnoDB: Retrying to lock the first data file
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unab131016 12:13:26  mysqld started
nohup: ignoring input
131016 12:13:26 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
131016 12:13:26 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
131016 12:13:26 [ERROR] Fatal error: Can't change to run as user 'user' ;  Please check that the user exists!

131016 12:13:26 [ERROR] Aborting

131016 12:13:26 [ERROR] Aborting

131016 12:13:26 [Note] /usr/sbin/mysqld: Shutdown complete

131016 12:13:26  mysqld ended

Open in new window

0
junipllcCommented:
The first thing I notice is that your disk is full. This command will verify that. You should see that one of the partitions is at 100%. You'll need to delete some stuff from that partition.
df -kh

Open in new window

Tackle that first and see if more errors pop up afterwards the next time you try to start mysqld.
0
id4382Author Commented:
Ok no problem, how will I know what can and cannot be deleted in there? Really kind of a noob when it comes to Linux, especially Gentoo, I don't want to delete something off of there and be in even more of a trap-shoot!

tarp ~ # df -kh
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda3              19G  2.9G   15G  17% /
udev                   10M  132K  9.9M   2% /dev
/dev/sda1              99M  5.6M   89M   6% /boot
/dev/sda5             9.2G  519M  8.3G   6% /home
/dev/sda6             9.2G  8.8G     0 100% /var
shm                  1012M     0 1012M   0% /dev/shm

Open in new window

0
id4382Author Commented:
I think I found the culprits. I found two files, /var/lib/mysql/ib_logfile1 and /var/lib/mysql/ib_logfile0, each of which were over 4GB in size. from the name I can gather these are log files, would it be safe to delete them without bringing harm to the system?
0
junipllcCommented:
No not those. That's part of the innodb.... Aka your data. I honestly don't know what to delete without knowing your system. I'd start by deleting log files, but not innodb logs.

I hope you read this I'm time ...
0
id4382Author Commented:
Well, that's a bummer. Yet, even after rm'n them, the folder capacity still reads at 100%.
0
junipllcCommented:
You deleted your ib_logfiles? Do you have a backup of them?
0
junipllcCommented:
Cam you post the output of df -kh?
0
id4382Author Commented:
I cleared out some of the *.log files and I was able to get some room cleared out. Now when I try to start, this spits out:

 * Starting mysql ...
 * Strange, the socket file already exist in "/var/run/mysqld/mysqld.sock"
 * it will be removed now and re-created by the MySQL server
 * BUT please make your checks.
 * Starting mysql (/etc/mysql/my.cnf)
 * MySQL NOT started (0)

Open in new window


Here is what the log file reads:

InnoDB: Skipping log redo
131016 16:32:55  InnoDB: Started; log sequence number 0 0
InnoDB: !!! innodb_force_recovery is set to 6 !!!
131016 16:32:55 [Note] Recovering after a crash using mysqld-bin
131016 16:32:54  InnoDB: Starting shutdown...
131016 16:32:55  InnoDB: Shutdown completed; log sequence number 0 8716
131016 16:32:55 [Note] /usr/sbin/mysqld: Shutdown complete

131016 16:33:02 [ERROR] Error in Log_event::read_log_event(): 'read error', data_len: 125, event_type: 2
131016 16:33:02 [Note] Starting crash recovery...
131016 16:33:02 [Note] Crash recovery finished.
131016 16:33:02 [ERROR] Can't start server: Bind on TCP/IP port: Address already in use
131016 16:33:02 [ERROR] Do you already have another mysqld server running on port: 3306 ?
131016 16:33:02 [ERROR] Aborting

131016 16:33:02  InnoDB: Starting shutdown...
131016 16:33:03  InnoDB: Shutdown completed; log sequence number 0 8204
131016 16:33:03 [Note] /usr/sbin/mysqld: Shutdown complete

131016 16:33:44 [Warning] No argument was provided to --log-bin, and --log-bin-index was not used; so replication may break when this MySQL server acts as a master and has his hostname changed!! Please us
e '--log-bin=mysqld-bin' to avoid this problem.
InnoDB: The user has set SRV_FORCE_NO_LOG_REDO on
InnoDB: Skipping log redo
131016 16:33:45  InnoDB: Started; log sequence number 0 0
InnoDB: !!! innodb_force_recovery is set to 6 !!!
131016 16:33:45 [ERROR] Can't start server: Bind on TCP/IP port: Address already in use
131016 16:33:45 [ERROR] Do you already have another mysqld server running on port: 3306 ?
131016 16:33:45 [ERROR] Aborting

131016 16:33:45  InnoDB: Starting shutdown...
131016 16:33:46  InnoDB: Shutdown completed; log sequence number 0 8204
131016 16:33:46 [Note] /usr/sbin/mysqld: Shutdown complete

131016 16:34:12 [Warning] No argument was provided to --log-bin, and --log-bin-index was not used; so replication may break when this MySQL server acts as a master and has his hostname changed!! Please us
e '--log-bin=mysqld-bin' to avoid this problem.
InnoDB: The user has set SRV_FORCE_NO_LOG_REDO on
InnoDB: Skipping log redo
131016 16:34:12  InnoDB: Started; log sequence number 0 0
InnoDB: !!! innodb_force_recovery is set to 6 !!!
131016 16:34:12 [ERROR] Can't start server: Bind on TCP/IP port: Address already in use
131016 16:34:12 [ERROR] Do you already have another mysqld server running on port: 3306 ?
131016 16:34:12 [ERROR] Aborting

131016 16:34:12  InnoDB: Starting shutdown...
131016 16:34:13  InnoDB: Shutdown completed; log sequence number 0 8204
131016 16:34:13 [Note] /usr/sbin/mysqld: Shutdown complete

Open in new window

0
id4382Author Commented:
Did not have a backup of the ib_logfiles
0
junipllcCommented:
Do you have a backup of the database? Perhaps in SQL format? Because if you do, and you re-import the data from a backup, those ib_log files shrink.

I wonder if you have other mysqld processes just hanging because of the disk full error. When a disk becomes full it's nearly impossible to know what ends up happening. Try this:
ps aux | grep mysql

Open in new window

That will give you all the processes running mysql. If you see one running, then you can kill it by typing (as root):
kill -ABRT <pid>

Open in new window

where <pid> is the process id of mysql. Or you can try:
killall mysql

Open in new window

or
killall mysqld

Open in new window

depending on the name of the process running. There's a good chance that there is a lingering process holding up port 3306, if the logs are correct.
You can also try restarting the server, which will clear out any dead processes.

Mike
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
id4382Author Commented:
Thank you! After the final process kill all, that released whatever was still holding on. I was able to start mysql and apache2 and the website is back up again. Strangely enough, all my db's are still intact, at least the ones I use, not sure what I really deleted.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
MySQL Server

From novice to tech pro — start learning today.