Iphone accessing Exchange Server Remotely

We can access Exchange Server for inter-office email using an Iphone in the office, but when we connect through the VPN when out of the office on Iphone it will not connect to Emai Server.

Connection to VPN is successful, but cannot get email.

We use Exchange Server 2007. No problems from remote computers, just Iphones.

Any ideas?
Chuck0410Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alan HardistyCo-OwnerCommented:
Why are you using VPN?  Isn't Activesync setup to work externally?

What is/are the FQDN(s) on the SSL certificate installed on the server?  What is the servername configured on the iPhone?

Alan
0
Chuck0410Author Commented:
My knowledge of exchange server is limited.

(1) Activesync is active on the Exachange Server. How do I get it to work EXTERNALLY?

That may be the problem.

(2) How do I find the name of the SSL certificate installed on the server?

Our VPN is a Linksys and uses PPTP so server name was the wan ip of the VPN.

(3) Can you help me with setting up activesync to work externally and installing SSL certificate on Exchange Server 2007 and on Iphone?

We don't have an ISA Server. Is that needed?

I simply want to get our users access to Exchange Server emails from outside the office.

I setup Exchange Server for user access locally and they can access via VPN using computer.

Beyond that, pertaining to iphones I am a lost puppy...

Thank you
0
Alan HardistyCo-OwnerCommented:
All that is needed to get Activesync to work is to install a 3rd party SAN / UCC SSL certificate and about the cheapest place to get one is GoDaddy.com (or a reseller site is actually cheaper) and then open up port 443 on your firewall and forward that to your Exchange Server.

You can test if this works or not on https://testexchangeconnectivity.com

To have Activesync automatically configure the iPhone, you need to setup a new A record called Autodiscover and that should point to your Public Fixed IP Address.

You should add autodiscover.yourdomainname.com and whatever.yourdomainname.com to your SSL certificate (the whatever name could be mail or www or some other name that has a corresponding A record pointing to your Public IP Address).

Alan
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Chuck0410Author Commented:
No need for it now, but answer appears correct.

Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.