Canon Scanner will scan in windows but not the Canon app.

I have a Canon MF6500 all in one scanner installed via USB on a windows 7 desktop.  The Canon works great except when I try to scan from the Canon toolbox application.  I get an error that the scanner is not active or in use by another application.   I am able to scan from Devices and Printers without a problem. Windows is taking control of the scanner and not allowing the Canon toolbox cannot access it.

I have turned off the Windows Scanning and Fax Feature but that did not help.  I have removed and reinstalled several times with different configurations (scanner not connected or scanner connected).

Is there a way to allow the Canon software to access the scanner first, or turn off Windows scanning altogether?  I have installed a number of Canon scanners in my IT career but I have never ran into this issue.

Thanks for the help!!
nexxtepAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Have you got the Windows 7 driver for the Canon All-in-One?  I use HP All-in-One printer/scanners myself and for clients and the scanner works with the HP software (I use it a lot).

That Windows is trying to take it over says that the proper scanner driver from Canon was not installed. Since you installed/reinstalled, that says you need a newer Windows 7 driver.

.... Thinkpads_User
0
nexxtepAuthor Commented:
Thanks for the reply, I have the latest Windows 7/8 driver from the Canon website.  I will double check, but I am pretty sure its the right driver.
0
JohnBusiness Consultant (Owner)Commented:
Try uninstalling the printer and the scanner from Control Panel, Programs and Features. Uninstall anything related to the Canon machine.

There are printer drivers that live in Printer Server Properties, Drivers tab, but I do not see scanner drivers there.

So after uninstalling as per above, restart and try reinstalling fresh.

... Thinkpads_User
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Joe Winograd, Fellow&MVEDeveloperCommented:
I'm not aware of any way that Windows can "take control" of a scanner such that other software cannot access it. I think the problem is somewhere else.

My first recommendation on scanning problems is to install the latest driver from the scanner manufacturer's website, but since you say that you have the latest W7/W8 driver from the Canon website, the culprit is probably elsewhere.

I'm not saying this is the permanent solution, but as a troubleshooting step, I suggest trying another piece of software to scan. IrfanView is excellent (free!) imaging software that I've been using for many years:
http://www.irfanview.com/

Click the Download link on the left to download IrfanView and click the PlugIns link on the left to download the PlugIns, which are needed to give you PDF capability (it's optional...only if you want PDF support...and the other features that come with the PlugIns). Install IrfanView first, then install the PlugIns (again, it's optional, but I think it's a good idea).

When you run IrfanView, click the File menu and pick [Select Scan/TWAIN Source...]. You should see both TWAIN and WIA drivers. If you don't, that's a huge problem; if you do, try both of them and let us know what happens. Regards, Joe
0
nexxtepAuthor Commented:
Thanks for the update, and you are right I dont think it was a case where Windows  was blocking access to the scanner but I think I found the problem.  I ran the Windows program compatibility troubleshooter selected the Canon Toolbox and it worked, I could not get it to save the settings but it did work.  I just have to get the compatibility mode to save the settings.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Joe Winograd, Fellow&MVEDeveloperCommented:
Ah, Compatibility Mode...good catch!
0
nexxtepAuthor Commented:
I was able to resolve the issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.