OWA in exchange 2010 error 405 - HTTP verb used to access this page is not allowed.

Dear Experts,

We have SBS 2011 running in our office.  When any of the users try to use OWA to access their email remotely they use IE and go to https://mail.companyname.com/owa.  This presents the normal login screen and they are prompted for username and password as usual.

On clicking Sign-in they get the following error in the browser;

405 - HTTP verb used to access this page is not allowed.

The page you are looking for cannot be displayed because an invalid method (HTTP verb) was used to attempt access.

As far as we can see there hasn't been any recent update applied and the server has not been reset within the last few days.  All the usual things like repair my network, iisreset etc are not helping. Really at a loss here.
LVL 1
tech53Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will SzymkowskiSenior Solution ArchitectCommented:
Have you tried doing this from a different browser? Does this happen with every user? Have you checked your IIS logs on your CAS server?

Also take a look at this as it might resolve your issue...
http://support.microsoft.com/kb/941201


Will.
0
tech53Author Commented:
Thanks will.

It happens with all users. If I reset all the virtual directories, will it mess up anything that Sbs relies on? I'm thinking about the wizards and the like.

Cheers
0
Will SzymkowskiSenior Solution ArchitectCommented:
If you reset the IIS virtual directory for Exchange it will only affect Exchange and nothing else.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

tech53Author Commented:
In EMC > server configuration > client access   Theres an option to "reset virtual directory"

Will that do the same thing?
0
Will SzymkowskiSenior Solution ArchitectCommented:
That is correct. In Exchange 2003 you had to reset the virtual directory from IIS which can now be done from the Shell or Console, in later versions of Exchange.
0
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
As said can you browse the VD's using IIS ?
Did you happen to upgrade the Exchange recently ?
Did you try the UpdateCas.ps1 ??

- Rancy
0
tech53Author Commented:
I performed the reset virtual directory procedure in EMC on the owa and ecp directorires. Ran the command iisreset /noforce but still I get the original issue when accessing owa.

one thing I noticed was that the www publishing service took a long time to stop but did eventually start again.

In IIS, I can successfully drill down into the owa and ecp directories and see lots of folders and files.

No upgrade to the exchange other than the Microsoft updates that come down periodically.

What is the UpdateCas.ps1?

thanks
0
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
sometimes after the upgrade with SP or RU the VD's have such issues with OWA and runnng the Ps1 does helps fix the issue

- Rancy
0
tech53Author Commented:
just ran it there but still same issue. Do I need to restart any services?
0
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
If possible restart the server and let see if that helps if not do check for Event viewer

- Rancy
0
tech53Author Commented:
Restart didn't cure it.  SP2 for exchange 2010 is available. I should install that. Not sure if it will fix it though.  It seems to be an IIS issue.

Also, found this  

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/Q_27461885.html

Do you think it applies?
0
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
You should go for SP3 as SP2 already out of Support

Sure that article speak a lot and are you getting the same events ?

- Rancy
0
tech53Author Commented:
Dammit!  SP3 installed but still the problem exists.

Yes, getting similar events as identified in that other article. It's a bit vague though and seems a bit drastic.

Is there any way to perform a 'reset to default' for the IIS configuration?
0
tech53Author Commented:
OK folks.  I ran the BPA on the SBS and several warnings were reported. I performed the following as per the recommendations:

- install exchange server 2010 SP2 (in installed SP3)
- run the psconfig program to complete the sharepoint update process
- in IIS browse to and rename the web.config file

I believe that the problem was the web.config file.  Its not supposed to be there. It contains configuration instructions that override the default settings for some/all IIS websites causing them to fail.  I don't know how it got there.  I'm assuming that is was created during the installation of a 3rd party program that is used in this server  to accept data from mobile handheld devices which the field engineers use. Perhaps it was created by a wizard or something.

Anyway, to solve this issue:
- launch IIS manager
- drill down to and select 'default website'
- in the action pane, click Explore
- rename the web.config file

OWA is working fine now.

Thanks for your help in troubleshooting this issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Good to know and thanks for sharing the brief details :P

- Rancy
0
tech53Author Commented:
OK folks.  I ran the BPA on the SBS and several warnings were reported. I performed the following as per the recommendations:

- install exchange server 2010 SP2 (in installed SP3)
- run the psconfig program to complete the sharepoint update process
- in IIS browse to and rename the web.config file

I believe that the problem was the web.config file.  Its not supposed to be there. It contains configuration instructions that override the default settings for some/all IIS websites causing them to fail.  I don't know how it got there.  I'm assuming that is was created during the installation of a 3rd party program that is used in this server  to accept data from mobile handheld devices which the field engineers use. Perhaps it was created by a wizard or something.

Anyway, to solve this issue:
- launch IIS manager
- drill down to and select 'default website'
- in the action pane, click Explore
- rename the web.config file

OWA is working fine now.

Thanks for your help in troubleshooting this issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.