Precision M6500 Mouse Won't Move to Right on Touch Pad

I've recently purchased a M6500 refurbished.  The OS is Windows 7 64bit.  The problem I'm having is the mouse for no specific reason will sometimes not move right when using the touch pad.  I've installed the synaptic drivers, Dell drivers and followed a couple other suggestions from the below thread.

I have also performed a clean installation using just the drivers listed for this service tag from Dell's site.  This fixed the problem for roughly a day but now its back to acting up.  Not as much as before but still not acceptable.  I've pasted a video of the exact problem and a rather lengthy thread on a Dell forum about this type of problem.  I'm hoping this can be repaired without parts replacement.  When using an external mouse or the touch stick all is well.  Thanks in advance.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

It's performing just as if you had 2 fingers touching the device at once.  It is acting like something is touching it on the right side of the pad and then when you put your finger on the left side of the pad it jumps over there and then goes right.

I would be willing to bet that there is an issue with the touchpad itself. You could try to push firmly and rub it up and down from right to left and then back again and see if that fixes the problem.  Otherwise I don't know if there will be much you can do other than getting a new touchpad or an external mouse.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
1namylnAuthor Commented:
That is exactly how its performing.  Only on occasion though.  Since I installed the driver directly from Dell's site it still happens but not very often.  Additionally, sometimes the tapping isn't as sensitive as it normally is.  For example I'll tap to select an icon and its like nothing happened.  Also I have noticed when the problem occurs I can use about 1/4 of the bottom right of the touch pad and it works but if I go outside of this imaginary square it goes haywire again.
You can try the method I mentioned above.

You could try to push firmly and rub it up and down from right to left and then back again and see if that fixes the problem.

Or you could try downloading the Synaptics drivers straight from their site here.  It seems as you may have already tried it.

Honestly it sounds like a broken touchpad to me but try the above and if they don't work then you will have to replace or repair.
ebay Touchpads
Danny ChildIT ManagerCommented:
If you try an Ubuntu Live DVD, you can see whether the error recurs.  If it does, it has to be hardware-related, as you're using a completely different OS and drivers.

You may also be able to do some testing in the same way if your BIOS has mouse support.
1namylnAuthor Commented:
Normally I'd replace the touchpad and move on.  I'm reluctant to just yet due to that long forum post.  

I will try the live CD.  Been working fine since I made this post.  A gremlin.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.