Direct Access on Server 2012

I was installing RRAS on server 2012 standard. The server is a DC. By accident, my tech started configuring Direct Access. To try and clear the problems that sprang up, we decided to remove RRAS and start over again. RRAS won't unistall until Direct Access is removed and Direct Access says that the configuration needs to be removed before the feature can be removed.

I can't remove Direct Access configuration. How can I get Direct Access removed?
Who is Participating?
JAN PAKULAConnect With a Mentor ICT Infranstructure ManagerCommented:
for essentials there is a hotfix

for you

do that

Can you try setting a new IPsec certificate using the Set-DAServer powershell cmdlet?
Example usage:
List root certificates using: "Get-ChildItem Cert:\LocalMachine\Root"
Select the certificate you want: "$certificate = (Get-ChildItem Cert:\LocalMachine\Root)[IndexOfTheCertificateYouWant]
Change the root certificate in the DA configuration: "Set-DAServer -IPsecRootCertificate $certificate"
Now try to open the management console again.

make sure that you run powershell as administrator

if that doesn't work try that

delete the value in the following register:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RaMgmtSvc\Config ServerGPO
LostInWindowsAuthor Commented:
Thanks a lot, that fixed it.
JAN PAKULAICT Infranstructure ManagerCommented:
Which step fixed it?
LostInWindowsAuthor Commented:
The first section, the same as outlined on the social.technet site.
JAN PAKULAICT Infranstructure ManagerCommented:
Brill. Thanks
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.