After fresh Windows 7 64bit install, Windows Update does not work.

Gentlemen,

This is immediately after a fresh installation of the OS onto a blank hard drive.

Note this is from an ASUS laptop computer (K series), and 4 DVD disks were produced by the original hard drive prior to installing them onto a new and blank hard drive.  

The initial complaint when running Windows Update (WU) was that the services weren't running.  Checked the services (WU and BITS, and both are shown running in administrative tasks -> Services).  

Note that no antivirus has been installed.  And no web surfing/ browsing has been done with this machine, other than to retrieve the specific downloads from MSFT which were identified using a different computer.  

Note that after doing all of the following troubleshooting, and did not vary the problem, I Turned WU off then back on again, and now there is a silent failure when clicking on the "Check for updates" button.  Note that both "most recent check for updates" and "Updates were installed" both report "Never".


Here's what I've done so far:

Machine originally had IE 8 as it's web browser.  

Burned Windows 7 64bit SP1 onto a disc, applied SP1, and was presented with a "catastrophic failure" soon after starting.  Error: E_UNEXPECTED (0x8000ffff)

Attempted install of IE9, but it reported that an updated needed to be applied prior to IE9 install (see next).

Downloaded and tried to install an update called "Windows6.1-KB2454826-v2-x64", which presented a permission elevation for "wusa.exe".  Error message: "Installer encountered an error: 0xc8000247".  (failed!)

Installed IE 9, successfully.  No change to WU failure.

Downloaded and ran the Windows Update Diagnostic tool X2.  Problems were found, some were fixed, one was not.  (unclear on how to identify the specific failure, but it was to the section "Problems installing recent updates" still has a red X next to it.)  No change.

Reset Windows Update components.  No change to WU failure.

System Update Readiness Tool, file called "WindowsUpdateDiagnostic" (running it presented a permission elevation for msdt.exe). It reports "Restart your PC" because some changes were made.  Clicking on Next, shows "Resolving Problems".  Problems found:
Problems installing recent updates   Not Fixed   X
Problems installing recent updates   Not Fixed   X
Check for missing or corrupt files     Detected   ! (in a yellow triangle)
Some security settings changed        Fixed         check
Service registration is missg/corrpt  Fixed         check
(clearly some problems are persisting, but I am so far unable to get enlightenment as to what the found problems actually were)
(I did see a log file filespec flash by quickly when I reran the tool to capture this error message ...)

Note that running the Microsoft Fixit tool for WU produced the same result.

Downloaded and ran the Windows Update Standalone Installer, file called "Windows6.1-KB947821-v28-x64", (running it presents a permission elevation for wusa.exe).  Error "Installer encountered an error: 0xc8000247".

Found that the log file that WU is supposed to produce in %windir% is not present.  


I've troubleshot this problem as far as I can and need to ask for help.  I've ordered OS reinstall disks from ASUS, and their result was absolutely abysmal (eg: about 15 devices remained undefined in the Device Manager, including the Chipset.  and the touchpad didn't work anymore.)

This is my third attempt to reinstall the OS, and to get Windows Update to work - which it so far hasn't.

Thank you in advance for your help.
LVL 3
ChrisEddyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bigeven2002Commented:
Hello,

Based on your extensive troubleshooting, I am suspecting that either the reinstall discs have a problem or that there are signs of hardware failure since Windows is having trouble from the get go, notably the disc drive, hard drive, or ram.

How old is the laptop?  If it isn't too old I think ASUS can still provide individual drivers on their website.  It might be worthwhile obtaining all of them and copy them to a jump drive, that is if the USB drivers are working correctly still.

You can also obtain a software that can do hardware diagnostics from a boot disc such as Ultimate Boot CD.

So from the above here is what I would suggest trying:

- Reinstall windows from a different DVD drive such as an external USB one.
- Apply the drivers downloaded to the jump drive and install them.
- Download Ultimate Boot CD or something similar, you may have to compile it but the site provides instructions, then run a full hardware diagnostic to see if anything is wrong with the hard drive or ram.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nobusCommented:
did you run sfc, or a repair yet?
http://www.sevenforums.com/tutorials/681-startup-repair.html            REPAIR
http://www.sevenforums.com/tutorials/1538-sfc-scannow-command-system-file-checker.html         SFC

also - are there errors in device manager
or in event viewer?
0
Darr247Commented:
How to run SFC

click the 'start' orb
type in cmd
hold down a Ctrl key and a Shift key, hit Enter, and release the Ctrl+Shift keys. (or right-click the cmd that appears at the top and choose Run as administrator.)
answer Yes to the UAC promptUser Account Control promptIn the Administrator: C:\Windows\system32\cmd.exe window that opens, run:

sfc /scannow

Have your windows install DVD handy in case System File Checker says it's needed.


Reset Windows Update Components
Run the Fixit tool for Win7/8 at http://support.microsoft.com/kb/971058


To better advise you, we really need to know more than 'ASUS K series.'
e.g. *which* K series, and its specific model number.
There are literally hundreds of different K series + models, and we need to know which chipset yours has to get you to the latest Intel Rapid Storage Technology driver (or if that's even needed at all).
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

nobusCommented:
Sarr - is that not the same i posted just above? if not, what is different?
0
Darr247Commented:
bobus - no, it's not.  

In what way did you think it was?
0
masnrockCommented:
Try a different Windows DVD, and reinstall from there. If things work from there, then you've found your issue. Also, did you check your hard drive for any issues?
0
Darr247Commented:
Here's a better link to the Intel Rapid Storage Technology driver, if your ASUS even uses it.

Intel Rapid Storage Technology driver

That should return only 16 possibilities instead of 26.
0
ChrisEddyAuthor Commented:
Gentlemen,

Thank you for your interesting and thoughtful responses.  

Some answers:

1)
a) This machine is a couple of years old.  I estimate 3 years old.
b) I did the manual "get-the-drivers" thing after the first installation failed, and did not vary the problem of Windows Update consistently failing.  
c) I have several hard drive and hardware diagnostics - and I will use them, and report results.
d) Due to the nature of this machine, it can only boot from the internal cd/dvd drive, and cannot boot from an external cd/dvd drive.  (yes, I have tried.)  Note that I have replaced the internal cd/dvd drive with a new drive, because the original drive would spontaneously quit while reading or burning a disc (which was frustrating).  

2)
a) I have not run SFC.  Good idea.  I'd like to believe that, since this is a fresh and virgin installation of the OS onto a blank hard drive, I'd like to believe that the install would produce an error free result.  But we all have wants, and I am one of them.  I will do this before running the hardware and hd diagnosics, and will report results.
b) I have already run the fixit tool for Windows Update, both the tool itself, and the entire tool which is stand alone and portable to another machine for troubleshooting a problem.  Other than finding a problem, shown above within my original problem report, is completed and did not vary the problem.

3)
a) So far, I have made 3 installation attempts, using 3 different sets of installation discs.  If I do use a 4th set of discs, it will be from a full retail OS installation disc - but I'd rather not go there just yet as a test to rule something in or out.  
b) Again, I will test the hard drive and the computer using one or more standalone hard drive and hardware diagnostics, and will report results.

4)
a) On the Intel RST drivers, yes I did see references to that during my earlier research phase.  However, I don't think I got relevant drivers for the prior install attempts.  Thank you for the (reasonably) direct link!  I will try that first - the next time I work with the machine.


Here is some additional information which might be interesting or useful to you all:

1) The hard drive is a new 1TB SSD/HD hybrid made by Seagate.  I have not tested it, because "new parts never fail".  Ehem, they actually do.  I do have good diagnostics, and I will test this drive, and actually form an informed opinion.  (btw: based on no information other than air, I wonder if there is somehow a cacheing issue that is somehow introduced by this drive.  I'd like to believe that this is not the case, because both MSFT and ASUS are both large companies, and I think it reasonable to expect that at least one of them would have tested the OS installation procedure using a hybrid drive.)

2) There have been 2 other install attempts prior to this one, and this has been over the past several weeks.  The first attempt used reinstall disks that were reported to be produced by the customer, which completed successfully, however windows update would not work - just like this, making this an operational failure of the install.  The second attempt used reinstall disks which I ordered from the manufacturer, which seemed to complete successfully, but the touch pad would not move the mouse pointer, and the device manager showed many yellow triangles next to devices without drivers properly assigned.  I troubleshot this install extensively, was unable to vary the problem set, and eventually declared this installation a failure also.  I remain somewhat shocked that the installation disks from the manufacturer would produce anything other than perfection.  This third attempt used installation discs which I produced from the original hard drive myself, so I at least know where and from what machine they came from with 100% certainty.

3) After the first installation, and Windows Update was consistently failing, one of the things I did was to run the MSFT tool which validates that this machine is running a legitimate and licensed copy of the Windows OS.  The tool completed, and reported that this installation was indeed Genuine.
0
bigeven2002Commented:
Ok thank you for the update.  Let us know the results of SFC and the diagnostics.

I find it strange that computer would not allow boot from USB DVD.  I trust you already checked the BIOS setting that controls this?  USB boot has to be enabled and is sometimes disabled by default for some manufacturers.

Can you check to see if there is a firmware update for the hybrid drive?  There might also be a hotfix from Microsoft for this type of drive too.  This new drive may be a native 4K sector drive and I think there may be a fix needed to properly support it.

Here is a link to verify the format of the disk, has instructions for using fsutil:

http://support.microsoft.com/kb/2510009

Windows 7 Service Pack 1 should have improved the 4K drive support.  If fsutil shows it to be a native 4K sector drive, then create a windows 7 install disc with SP1 slipstreamed.  Then perform your 4th attempt with this disc.  This way it will have the proper drive support from the get go and may solve the problem.  You'll still need to install your drivers afterwards.

http://www.sevenforums.com/tutorials/145343-slipstream-windows-7-sp1-into-installation-dvd-iso-file.html
0
ChrisEddyAuthor Commented:
Windows SP1 64 bit was downloaded and burned to a DVD.  It was applied to the Windows 7 64 bit OS, but failed with a catastrophic error.  Please see above for the specific error code.  

I've checked the Bios settings for an option to boot from an external cd/dvd drive, or to enable that option.  There was no joy.  I will check the bios version, and update if not modern.

Thank you for the additional links for additional information.  Again, I will report results after the tests/ suggestions have been performed.

Btw: thank you for the impressively geeky link to slipstream in SP1 with the ASUS install disk.  However, this is more complication than I want to introduce right now.  And since SP1 fails to land onto the already installed OS, I suspect that slipstreaming SP1 into the installation procedure will mainly serve to automate the SP1 failure rather than serve as a necessary lubricant to make it go.  

Also, as a clarification: the OS reinstall disks which were produced by the original HD, are actually intended to produce the ASUS Recovery Paritition, rather than to directly install Windows 7 onto a fresh HD target.  Performing the actual installation of the OS is done by booting from the Recovery Partition.
0
Darr247Commented:
If you're not going to tell us which K series it is, and its model number, I'll be dropping out of this thread.
0
bigeven2002Commented:
Ok thanks for checking the BIOS, strange, I would have figured that a 3 year old computer should have the ability to boot from USB.

The slipstream integrates SP1 into the install disc which creates a new install disc for Windows itself.  I highly doubt this would automate the error.  This method requires a Windows 7 installation media as the recovery partition method won't work to do this.

I think the reason SP1 failed to install is because the initial Windows 7 version (installed from recovery partition) couldn't properly handle the hybrid drive to begin with.

Please continue your tests, we'll wait for your reply.  Thanks!
0
Darr247Commented:
Actually, a slipstream disk just applies the service pack after the initial installation is done... a Win7 DVD with SP1 slipstreamed is not the same as a Win7 w/SP1 installation DVD.
0
nobusCommented:
Hey Darr, sorry for the typo - my big fingers , you know

it starts looking  that the recovery DVD's are corrupt in some way, or you have hardware problems.
you can check that by running from a live knoppix cd -  to see if it runs well (but you can't apply updates) - suggest using the Knoppix cd :
http://www.ubcd4win.com/                              ubcd  Win
ftp://mirrors.kernel.org/knoppix-dvd/KNOPPIX_V7.0.5DVD-2012-12-21-EN.iso      Knoppix

another way would be by hooking your disk to a working system, and booting from it
It will start installing drivers, and then you could check if windiows updates do work or not.
best use a system with the same cpu brand  - intel, AMD -  as your ASus laptop
0
ChrisEddyAuthor Commented:
Since you asked, the model is K50ij (designated by ASUS as "BestBuy specific").
0
ChrisEddyAuthor Commented:
1) I've run "sfc /scannow" as an Administrator, and the following error message was displayed:
Windows Resource Protection found corrupt files but was unable to fix some of them.
Details are included in the CBS.log %window%\Logs\CBS\CBS.log.  For example
C:\Windows\Logs\CBS\CBS.log

I've included the complete log file for your review.  Please let me know what you think.
CBS.log
0
ChrisEddyAuthor Commented:
2) There are no undefined devices shown in the Device Manager, eg: there are no yellow triangles with an exclamation mark next to any of the devices.
0
ChrisEddyAuthor Commented:
3) On resetting the Windows Update Components, the Fixit utility has been downloaded and run as an Administrator.  

Unfortunately, the tool failed, reporting that Troubleshooting cannot proceed because th troubleshooter as experienced an unexpected error and cannot continue.  

Clicking on the link for more information, goes to a page with picture of a reasonable and thoughtful looking male, and a notice that this beta has been discontinued and will no longer be offered.
0
ChrisEddyAuthor Commented:
4) On installing/ updating the Intel RST drivers, there are apparently 2 things which Intel says relates to this.
On updating the Intel RST drivers, I've seen references to this as a possible cause.  And thank you for the specific link to the drivers.  

a) Running SetupRST as an Administrator, failed.  Reporting that the setup program ended prematurely because of the following error: This platform is not supported.  

I've included the log file which was produced, for your review.  

b) I've downloaded a zip file containing some new drivers and definitions from a file called f6flpy-x64, but there is no installation procedure or documentation included.  

Installing "isAHCIC" or "iaStorAC" both fail, reporting: "The INF file you selected does not support this method of installation".
0
ChrisEddyAuthor Commented:
I think I've answered all of the current questions.  Please let me know if I've missed something, or if there are new things to look at and for, or if new thoughts have arisen.

Thanks!
0
masnrockCommented:
Have you tried a Windows 7 DVD that already had SP1 slipstreamed on it? You can download the ISO file online pretty easily. This page has a number of legit links for Windows 7 ISO downloads. While you might still have to install a number of drivers, this should do you some good.

http://www.w7forums.com/threads/official-windows-7-sp1-iso-image-downloads.12325/

You've never cited whether you tried testing your hard drive and memory. If there is a possible hardware failure, I'd more likely suspect the hard drive. As odd as it sounds, sometimes you won't a hard drive issue until you install software. Try testing it.
0
ChrisEddyAuthor Commented:
Thanks for the direct link for a /different/ ISO!  I have lingering suspicions that the ASUS installation procedure is buggy.  I also have a Dell Windows 7 64bit SP1 installation disk, which might also be tried in a pinch.

I have not yet run a standalone hard drive diagnostic.  Thank you for the gentle reminder.  (and I will, this time!)

I will also run a standalone ram diagnostic.  And thank you the gentle reminder on this, also.  However, my past experience is that the OS tends to be a superior ram diagnostic.  I've seen some ram pass a good and long standalone diagnostic, but BSOD with random stop codes during or after the OS has booted.  This has not yet been seen.
0
ChrisEddyAuthor Commented:
Wanted to give you some status on the hard drive diagnostic.  In a nutshell, even though the test is not finished, it's over 1/2 done, and no errors have been found.

I've been running an inversion write test on this 1TB drive.  As of right now, the test is 5/7 complete, and no errors have been found.  Based on this rate of progress, I expect the disk test to be complete in about 1 more day.  

If the HD tests clear, the next step will be a long term ram test using the standalone memtest86.

If the ram tests clear, the next step will be another fresh installation of the Windows 7 64bit OS, but using the Dell install disks which already have SP1 applied.
0
ChrisEddyAuthor Commented:
New status: soon after the above status, I decided that >50% of actual completion of a write inversion test with 0 errors, is an operationally sufficient test - partly because no part of the OS could have gotten past 500GB into the disk.  So the disk has been proven good.

The ram test completed with no errors found.  Total ram is 4GB.

Did another fresh installation of the OS, but this time used a Dell installation disk.  After the installation completed, I manually launched Windows Update, and it didn't fail immediately like the ASUS manufacturer installation disks did.  I've successfully taken several waves of Windows Updates so far.  

So the current information indicates that at least the Windows Update portion of the ASUS OS installation disks are buggy.  (sarcasm: great.  thanks ASUS.)
0
bigeven2002Commented:
Thanks for the update.  The difference here is you used a Windows 7 setup disc that already had SP1 integrated so you started out with SP1 already installed.  As I figured earlier, this would likely resolve the issue as SP1 has better support for your hybrid drive.
0
ChrisEddyAuthor Commented:
Actually, this installation disk did not have SP1 already included.  Contrary to what might have been thought, and I also suspected this because what manufacturer would possibly ship or produce a bare-metal OS reinstall disk that had a damaged Windows Update capability, this indicates that the hybrid drive has no affinity for SP1.  

All OS updates, which were required before SP1, were downloaded and installed successfully.  SP1 has been installed from a standalone CD successfully.  Continuing to download and apply OS updates, until there are no more.  All updates have since been successfully downloaded and applied.

Current information still indicates: The ASUS OS reinstall disks, whether produced by the computer or ordered from the manufacturer, have a buggy and unrepairable Windows Update capability.
0
ChrisEddyAuthor Commented:
Unless anyone has any new information to offer or objections, I'm going to consider this problem to be solved, because the solution was to abandon the ASUS OS reinstallation disks and to instead use a completely different (read: non-ASUS) installation disk, because the ASUS reinstall disk and recovery partition are both unfortunately and subtly and irreparably buggy.
0
bigeven2002Commented:
Ok thanks for letting us know.  

My apologies but this has been the most confusing thread I have ever participated in.  Too many mixed signals...I thought the Dell disc had SP1 included (per your post 39610272) and then it doesn't (per your post 39613082).

But as long as the updates are applying now that's all that matters.  Take care.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.