Hyper-V VMs loose their VHDs under high load

Hi!

I've set up a Win Srv2012 with Hyper-V with a 7TB iSCSI NAS attached to the Hyper-V host. It's visible as an E: drive on the Hyper-V host.

I've then created a 3TB VHD on the E: drive and assigned it to the host as a SCSI drive.
Whenever the Virtual machine access this new VHD a lot - could be copying 1 TB of data to the new VHD or even just formatting the new VHD from within the Virtual Machine, it suddenly disappears from within the Virtual Machine. Not even a rescan can detect the SCSI VHD again.

The disk is still listed as attached in the VM Settings until  you reboot the VM - then its gone and all that is left is the SCSI controller.

There are no errors on the event log(s).

The Hyper-V host is running on a Dell Desktop machine with a Core i7 CPU, 32Gb RAM and a local 480Gb Intel SSD. There are no issues with the local disk.

Any help or directions would be much appreciated. I'm out of ideas myself (except bying a "real" $10K server for this, but it may be a bit of an overkill for this project.
TheGuru42Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Svet PaperovIT ManagerCommented:
There might be an issue with the network connection to the iSCSI NAS or with the NAS.

To improve iSCSI communication between the host and the NAS, you need to:
- Use an iSCSI-dedicated NICs on the host and on the NAS in separated IP segment  
- Enable Jumbo Frames and Flow Control on all network devices on the iSCSI path
- Enable TCP and IP Rx/Tx offload on the iSCSI-dedicated host’s NIC
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TheGuru42Author Commented:
iSCSI was running on a dedicated physical LAN
Jumbo Frames has been enabled now (4K frames - largest supported by the NIC)
Flow control enabled on all devices
TCP and RX/TX offload was already enabled on host NIC.

I'm giving it a try now. Let's see in some hours when the disk-abuse has finished :)

However. I might should have added that I tried with a completely different setup before using the iSCSI NAS. I had a RAID5 box attached directly to the Hyper-V server through the eSATA interface and the exact same thing happened back then.

Thanks for your help so far.

Br, Bjorn
0
TheGuru42Author Commented:
It worked like a charm!

Thank you so much for your help.

You saved me $10K ;-)
0
MaxEL_UACommented:
I'm affraid you of AV-Storm. I had familiar problems couple of monthes ago on FC connected storage. The CSVs are were stopped with their accoding VMs.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.