• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1057
  • Last Modified:

Cannot boot from Intel SSD 120GB

I have an MSI h55m E21 system board.  I also have an INtel 120GB Solid State Drive.

I installed Windows 7 on this drive, however every time now when I try to boot to it, after the first BIOS screen, I just get a black screen with blinking cursor.

In the BIOS I have set the SSD to be the first boot hard drive.  Still  no luck.
I have installed a conventional hard drive (Seagate 500GB) and installed windows 7 to it and it boots no worries, first time everytime, but I just cannot get the SSD to boot automatically.

There is a 2.2TB Infinity feature on the system board.  If I enable that, then go into the bott menu for that and boot from the SSD it boots no worries, but that means user inout on every boot up.

The SSD harddrive it self seems to work fine, so it must be a BIOS thing, but I just cannot see it.

I have updated the BIOS to not the latest but 1 version before the last BIOS updated version, still the same result, black screen with blinking cursor.
1 Solution
Just reset the bios and set again
Do you have the latest firmware for the Intel SSD as well?  Is this an Intel SSD 530 model drive?  If so, you're not alone:


The only workaround right now is to try disabling the AHCI mode in the bios.
did you install all the drivers?

here they are :  http://www.msi.com/product/mb/H55M-E21.html#/?div=Driver&os=Win7 64

you can also check if you can boot to safe mode - then it can be a driver issue
Will You Be GDPR Compliant by 5/28/2018?

GDPR? That's a regulation for the European Union. But, if you collect data from customers or employees within the EU, then you need to know about GDPR and make sure your organization is compliant by May 2018. Check out our preparation checklist to make sure you're on track today!

mbellettyAuthor Commented:
reset bios???  Tried dozens of times.

convergint: thanks for that info.  it was set to IDE mode which I assume means AHCI is then disabled already.

NO luck
mbellettyAuthor Commented:
nobus all drivers installed from CD.

I cannot even get it to read the SSD as a boot drive to then get into safe mode.  No way of getting to that step so safe mode not an option at the moment
What do you mean with user input every time if the infinity feature is turned on? Doesn't that feature stay set Once you have toggled it on? Or what other user input is needed?

From what I understand about that feature is that it allows you to boot m$ OS's from a GPT disk. So if your SSD has been initialized as a GPT disk you'll have to have that option set to on when you want to boot from the SSD. If you want to change it to an MBR disk, you'll have to re-install the OS to it, after converting it to an MBR disk (you should be able to do that with the SSD connected as a 2nd disk when you boot from your conventional disk, via disk management). After that remove the conventional disk, make sure infinity is turned off, and install Windows to the SSD.
>>  I cannot even get it to read the SSD as a boot drive to then get into safe mode.  No way of getting to that step so safe mode not an option at the moment   <<  i don't understand what you mean; can you or don't you want to boot into safe mode ?
mbellettyAuthor Commented:
Spot on Answer.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now