MS SQL Maximum Server Memory Setting Keeps going Back to Default

Hi

I’ve set the maximum memory usage in SQL to 40GB but I keep coming back to it (due to slow server speed) only to find its back at the default 2147483647 MB.

I’ve upgraded to the latest version of 2008 R2 (10.50.4000) but the same thing has happened again.  The server has not been restarted and neither has the SQL service.

I’m completely lost as to what could be causing this, has any one seen this before?  Any recommendation on what to do next?

Many thanks

Brasso
LVL 1
brasso_42Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lcohanDatabase AnalystCommented:
Is there any startup script or is this running on a VM that was initially took with that setting and restored? There is NO other way unless someone else (admin) goes in and changing it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.