Upgrading Vmware ESxi host from 5.1.0 (799733) to 5.1.U1

My two hosts are running ESXi 5.1.0 (799733) I would like to update to 5.1.U1 with IBM customization.  Will the command line upgrade (Esxcli software vib update –depot-/vmfs/volumes/DataStore1/patch/xxxxx.iso) work? for this I will have to upload the iso image to DataStore1 first
Simply put the CD in and it will upgrade automatically, will it pick up the previous version of 5.1.0?
If none of the above works, what is the best way of dealing with it, I would like to Upgrade so that all my settings are kept inplace.
Help plz
amanzoorNetwork infrastructure AdminAsked:
Who is Participating?
Andrew Hancock (VMware vExpert / EE MVE^2)Connect With a Mentor VMware and Virtualization ConsultantCommented:
You can upgrade in two ways:-

1. Use the ESXi Installer ISO, boot the CDROM, and Upgrade.

2. Download the Offline Update from the VMware Patch Portal, and use the command posted.


Esxcli software vib update –depot-/vmfs/volumes/DataStore1/patch/xxxxx.zip

note, not the iso, the zip file!
dipopoConnect With a Mentor Commented:
I would download the IBM customized image and use this for the upgrade, also please remember to perform a vicfg-cfgbackup of the hosts before attempting the upgrade.

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

amanzoorNetwork infrastructure AdminAuthor Commented:
Thanks for the reply.  I can see only the command how to backup.  I need to know how to upgrade.  Thanks

THanks for the reply;
1) When I boot my host from the IBM customized image of VShpere 5.1 Update01 will it pick up my old install?  Need to keep all my settings please?
2)Since I am using the IBM customized image for 5.1 I must stick to the IBM customized image for 5.1. UPdate01.
I do not have the zip file for this image from IBM only iso.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
1. Yes, it will detect existing installation, and advise you if you want to keep existing VMFS (VMs) datastore.

2. If using the installer (ISO) , you will need to use the IBM OEM version. If you have the offline version, you can try an upgrade at the console prompt, it will advise if it cannot upgrade.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.