Temporary Time Change in Windows 8

I have created a Windows 8 VM on a Window 2012 Server.

The VM is exhibiting the correctly expected behavior of keeping the time synchronized with the domain.

This is great most of the time, but I occasionally need to change the date for testing purposes when developing software.  

On my old Windows 7 physical machine I could make the change and it would stay in place until I changed it back or logged out and back in.

On the new VM, the time will change back to the domain time within seconds, which is not enough time for me to test.  I'm not sure if this is related to it being Windows 8, a VM, or something else entirely.
LVL 1
richnDirector of Information ServicesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bill BachPresident and Btrieve GuruCommented:
People don't usually TRY to break the time sync, because of the problems it creates.  You will probably have to configure a manual time source, and point it to an invalid computer:
    http://technet.microsoft.com/en-us/library/cc757721%28v=ws.10%29
0
SommerblinkCommented:
This VM... is it a domain member?

If it is not, then who cares about time synchronization. The reason why the time resets is because the Hyper-V Integration is providing the time to the guest.

You may want to investigate into option #6 from this link: http://blogs.msdn.com/b/virtual_pc_guy/archive/2010/11/19/time-synchronization-in-hyper-v.aspx

This shows how to partially disable the Hyper-V time sync. Of course, if rebooting your guest into the wrong date is required, this won't help. If that is the case, then simply disable Time Synchronization on the guest settings. This is located in settings, under Management / Integration Services.

Please note that there is an extremely good probability that your time will drift if you disable time sync this way.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
richnDirector of Information ServicesAuthor Commented:
Changing the Integration Services setting was the key.

You can actually change the setting with the VM running.  You can then change the time on the VM.

When you are done testing, renable the Time Synchronization setting and the time is immediately corrected on the VM.

This is exactly what I needed.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 8

From novice to tech pro — start learning today.