"the file or directory is corrupted and unreadable" error in normal boot mode, but clean in safe mode

I have a NAS drive that is showing "the file or directory is corrupted and unreadable" errors. The drive array is a large one at 16 terabytes or so.

When I boot into safe mode, I can read all directories that had errors with no issues.

What is the difference between safe mode and normal boot mode, when it comes to reading a hard disk (this one is connected through USB)?
Who is Participating?
LeeTutorConnect With a Mentor retiredCommented:
it may be because of some conflict caused by startup programs (which do not run in Safe mode) or some driver that is not used in safe mode.  In Windows 98/ME/XP/Vista/Windows 7, you can choose which programs are run at startup by using the Microsoft Configuration utility:  click on the Start button, choose Run, type in MSCONFIG (doesn't need to be all capitals), click OK.  Choose the Startup tab, deselect programs to run at startup by removing the check mark.  In Windows 9x/ME, you may need to disable just about everything except Explorer, ScanRegistry and SysTray.  In Windows XP/Vista/Windows 7, just click on the button for Disable All. Reboot and see if the problem goes away.  If it does then re-enable the startup programs one (or a few) at a time, reboot, and when the problem occurs again, there is your culprit.  If you have a great number of apps to narrow down on in trying to track down the culprit, do it instead by dividing up the loading programs into successively smaller halves:  disable half of them; if the problem doesn't go away, then the offending app is within the other half, so divide that group into half; or if the problem does go away, then the disabled group contains the offender, so again narrow down by dividing in half.  

In Windows XP/Vista/Windows 7: If the problem continues to come up with all startup programs disabled, then it is probably a driver or service.  You can click on the Services tab in MSCONFIG, click on the button for Hide All Microsoft Services, leaving only third-party services displayed, then try turning them off in the same way you did for startup programs.  Finally, if third-party services are eliminated from being the cause of the problem, you could try narrowing down on Microsoft services in the same way.
Generally, less resources are called/less processes are launched.

Have you run chkdksk /f /r form elevated command prompt? Also try sfc /scannow
synergypsp, any feedback?
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

synergypspAuthor Commented:
It takes 24+ hours to run a chkdsk on 16tb of data with a sector check over USB. Working on it. :-)
synergypspAuthor Commented:
Update - The sfc /scannow found no errors. The scandisk reported several errors that were fixed. But the issue is still there. Now going through disabling services/programs. Will keep you updated.
synergypspAuthor Commented:
The solution by LeeTutor solved the problem. It was a USB turbo drive, and a USB driver monitor that was added by third party software, for a controller card that is not being used. Commented out their execution in the registry and problem solved.

Thank you LeeTutor.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.